Subscribe

Has anyone successfully integrated with OnCommand (5.0) and WFA?

Hi,

I am trying to use two commands (namely "Refresh Monitor on Array" and "Wait for Monitor Refresh") and running them against an OnCommand 5.0 box.

I have setup the OnCommand box as a datasource and that is working correctly. I have also added it under the Credentials section where using test button it works correct. However when I run the above commands I receive.

Error: DFM Database Write permission denied on <<filer_name>>

The account has GlobalFullControl. The only thing I can think of is when I log onto the dfm terminal I must run DFM commands with the keyword sudo. I do not know the root password as that is part of the security framework that this server must abide by to be part of our environment. Could this be the problems or am I missing something?

Cheers,

Braiden

Re: Has anyone successfully integrated with OnCommand (5.0) and WFA?

Hello,

I'm trying integration of WFA with OC5.0.1, but on Windows server 2k8, I'm trying to connect WFA to DFM server using "credential" view, but when I try to connect to my DFM server, it seems to crash : "<adress_ip>:22 access refused", my OC server is Win server 2k8 machine and thats why I cannot connect on TCP port 22...

Is there a way to connect WFA to OC5 server in the "credential" view?

I've successfully connect WFA to OC5 sybase database using wfa_oc5setup.exe and follow the connection sstep into "Data Sources" view.

Thansk by advance for anybody could help.

Best regards,

Yannick

Re: Has anyone successfully integrated with OnCommand (5.0) and WFA?

Hi Braiden,

Well, I happened to stumble on your question by mistake as it was posted here and not in the WFA community.

I am not certain about the answer though, so I will check into it and get back to you (Hopefully it would be still relevant).

Generally, we currently use SSH to work with the OnCommand (We do plan to switch to ZAPI sometime in the near future).

With that said, I am not certain this constellation (Linux OnCommand with a non-root user) was thoroughly examined and I will check it out.

Since we mostly check connectivity on the credential testing - It makes sense that the test passed successfully.

I will update this space once I will have a definitive answer.

Best,

Yaron Haimsohn

WFA Team

Re: Has anyone successfully integrated with OnCommand (5.0) and WFA?

Hello Yannick,

Pleased to meet your acquaintance.

1) In order to acquire information from the OnCommand you have to set it up as a Data Source in WFA. Just follow the instructions in the installation and Setup guide.
Note that you'd have to run OC5Setup.exe before (As you did) and if you follow the instructions in Appendix D of said document you'd be able to cache information successfully.

2) OnCommand credentials are required ONLY if you plan to use any of the WFA commands that run on the DFM (Such as the Refresh or Wait command). Since WFA is using
SSH (At the moment) to connect with OnCommand for command execution, you may need an SSHd installed on your OnCommand machine. In WFA community there are some threads
about this topic.

I'd recommend taking a look and posting WFA related questions under https://communities.netapp.com/community/interfaces_and_tools/wfa

We would see it and answer faster there :-)

BR,

Yaron Haimsohn

WFA Team

Re: Has anyone successfully integrated with OnCommand (5.0) and WFA?

Thank you Yaron,

I'll follow the link.

I finally use FreeSshd on my dfm server at this time, and by that mean I've successfully connect to DFM via WFA accross SSH, Now I'm trying to run some example workflows!

Have a nice day,

BR,

Yannick,

Re: Has anyone successfully integrated with OnCommand (5.0) and WFA?

Hello Yannick,

Was this answered? Can you please mark it as answered?

Thanks,

Yaron

Re: Has anyone successfully integrated with OnCommand (5.0) and WFA?

Hello Yaron,

Seems that I can't mark this post as Answered, because I'm not the owner (owner is braidenjudd).

By the way I've mark your answer to my post as recommended.

BR,

Yannick