Subscribe
Accepted Solution

How can I tell if the cache is being populated?

My workflows are not executing.

My filters are not returning values.

The status of my data sources are "scheduled".

I'm starting to think my cache is not being populated. How can I verify that the cache is being populated?

Troubleshooting:

I can successfully test connectivity via the "credentials".

I have gone through the troubleshooting guide and I see the following.

Failure in acquisition – The first thing to verify is the connectivity to the DFM. Open a telnet

from the WFA server to the DFM on port 2638. Wait for either the loopback to appear or for

the connection to timeout (Which means the port is blocked on the networking level.

I try to telnet but I just get a blank screen that just sits there. However, I know that nothing is being blocked on the network side. So this step does not make sense. Do I need the telnet server installed on my Windows machine?

Re: How can I tell if the cache is being populated?

The fastest way - Without relating to the actual issue at hand:

1) Remote desktop to your WFA VM

2) Download a MySQL DB viewer (Contact me via email to get a registered version for NetApp internal machines).
We recommend SQLyog from www.webyog.com

3) Open a connection to the local host using a user that grants R/O permissions to the cache:

Username - wfa

Password - Wfa123

Note: The user is available from 1.1 onward only.


4) Take a look at the storage DB (on the left side) and select the third tab on the bottom right half for "table data")

A semi faster way - Select a basic certified finder (Let's say "Find aggregate by available capacity"),

find it and open it in the "Finders" list, and press the test button.

Typing 10 in the input field would return all aggregates in the cache that have at least 10MB (!!) free,

and that are not named aggr0.

If something comes back - That's info from your cache.

Yaron Haimsohn

WFA team

Re: How can I tell if the cache is being populated?

Hi, thanks for the info. I will prolly have to engage you directly.

I tried the "semi faster" way and I am not returning any results.

So I'm not sure. Everything seems to be configured. But nothing is working. Since the semi fater way is not working I think it would be safe to assume my cache is not being populated for some reason. Even though my authentication tests are working and I have followed all of the steps in the install guide.

Re: How can I tell if the cache is being populated?

In the Data Sources screen, right-click on a data source entry in the upper part of the screen and choose 'Acquire now'. This should result in a new entry in the history table in the lower part of the screen. Wait for the acquisition to finish and check if the status is 'Completed' or 'Failed'. If it fails, the message column should give you a hint why it failed.

Hope that helps

Hendrik

Re: How can I tell if the cache is being populated?

Hland, as I mentioned in my first post.

The status of my data sources are "scheduled".

They never change.

Re: How can I tell if the cache is being populated?

Just to close the loop on this one. Everything appeared to be installed correctly. After working directly with Yaron we decided to uninstall/ reinstall. That seemed to do it. Everything started working after that. I have submitted a backup and autosupport to Yaron for evaluation. Thanks for the help!