Subscribe

How to enable port 80 (web gui) access to WFA server from client with W2K8 firewall

I haven't seen this listed anywhere so here is something I hope helps others.  My Windows 2008 WFA server is running Windows Firewall and I didn't want to turn it off for security reasons.  However, it was blocking port 80 access to WFA from any other system so I could only manage WFA when running a browser while RDP'd into the WFA server itself with the localhost url.  Here are the steps to configure Windows firewall to permit port 80 access to WFA from outside clients.  This is for WFA 2.0 but will work for older versions as well (but it may be under the x86 install path).

Apologies if this is a repeat of information I haven't found.

1) Go to Server Manager and then Configuration->Windows Firewall->Inbound Rules.

Enable BranchCache - Content Retrieval (Uses HTTP)

2) Go to Start->Run and type firewall.cpl

3) In the window that pops up from step 2, click on the left side link that says:

Allow a program or features through Windows Firewall.

4) In the new screen, click on the "Change Settings" button at the top right.

5) Towards the bottom of the window click on the "Allow another program..." button

7) In the window that pops up you will need to "Browse" and add the WFA program located here:

C:\Program Files\NetApp\WFA\bin\NA_WFA_SRV.exe

This is what the "NetApp WFA Server" service runs.

You will now notice it stated as "Commons Daemon Service Runner" in the list of allowed programs.

8) Click OK and then bounce the WFA service.

Hope this helps.

Re: How to enable port 80 (web gui) access to WFA server from client with W2K8 firewall

Dave,

This is excellent information & Thanks for sharing!