Subscribe
Accepted Solution

How to increase JBOSS heap size in WFA 4?

Recently, our WFA 4.1 instance has been experiencing stability issues. In the server.log we are seeing errors such as:

 

 

Caused by: java.lang.OutOfMemoryError: Java heap space

 

 

I'm definitely no JBOSS expert, but I poked around the install location of JBOSS, and found a couple files that look like I can increase the heap size, with the JAVA_OPTS Xmx parameter:

 

C:\Program Files\NetApp\WFA\jboss\bin\standalone.conf.bat

C:\Program Files\NetApp\WFA\jboss\bin\standalone.conf

 

Has anyone attempted to do this before? I searched KB articles, but couldn't find anything. The defaults are as follows (from both files above):

 

"JAVA_OPTS=-Xms64M -Xmx512M -XX:MaxPermSize=256M"

I'm thinking of doubling or tripling the Xmx value. Thoughts?

Re: How to increase JBOSS heap size in WFA 4?

A side note: this is unconfirmed so far, but it seems we had a CDOT cluster decommissioned without first removing it from OCUM/WFA. We are theorizing that this may have caused this memory issue. Hopefully the proposed heap size increase will still help in the future.

Re: How to increase JBOSS heap size in WFA 4?

@jauling_chou

 

The deafult value for Java heap in WFA is -Xmx1536m. But vefore we look to increse it, I want to ask some questions.

 

 

1. Is your WFA on windows or linux?

2. What is the problem in WFA you are fcaing. The log messages are fine, but is there some workflow or some failure that you are seeing in WFA?

3. Have you got the recommended space and memory requirements on your WFA windows box?

 

A side note: this is unconfirmed so far, but it seems we had a CDOT cluster decommissioned without first removing it from OCUM/WFA. We are theorizing that this may have caused this memory issue.

-------

 

Not likely the cause.

 

sinhaa

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: How to increase JBOSS heap size in WFA 4?

Apologies for the extremely delayed response.

 

What files did you find the -Xmx1536m setting? Both the standalone.conf and standalone.conf.bat files in C:\Program Files\NetApp\WFA\jboss\bin\ showed me -Xmx512M as I mentioned above. This most likely means I modified the wrong files, can you confirm?

 

1. Is your WFA on windows or linux?

Windows VM

 

2. What is the problem in WFA you are fcaing. The log messages are fine, but is there some workflow or some failure that you are seeing in WFA?

The log message of java.lang.OutOfMemoryError are fine? We were experiencing REST timeout issues when running workflows and filters. Our ops guys would restart the WFA service, but a few hours later it would stop responding again. That's when I was engaged, and I found the heap space error.

 

3. Have you got the recommended space and memory requirements on your WFA windows box?

We have not officially asked for space/memory requirements from NetApp support, but we do have an inhouse TAM who I would guess have sized the Windows VM appropriately. The VM is sized as 4 vCPU + 10 GByte memory.

 

FWIW, I often see SQLWarning messages in our remote syslog collector coming from the WFA4 instance. I will escalate those separately.

Re: How to increase JBOSS heap size in WFA 4?

@jauling_chou

 

The log message of java.lang.OutOfMemoryError are fine? 

------

 

What I meant was, we got to understand about the error in logs but wanted to know what is really affecting your WFA experience. You have provided that info. Thanks.

 

 

I suggest you open a Technical support case to debug this further on reasons why this is happening. This could be an important issue. I can tell you how to increase the Heap memory, but I'm not aware of what unwanted  consequesnces it can bring ( if at all ).

 

So to be safe, file a Technical support case. 

 

 

sinhaa

 

 

 

 

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: How to increase JBOSS heap size in WFA 4?

FYI, I think this should be public knowledge, but feel free to delete this message if you feel differently.

 

In order to increase the JBOSS java heap size, a modification to the Windows registry is necessary. I'm not sure how its controlled in Linux.

 

Navigate to the key named:

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Apache Software Foundation\Procrun 2.0\NA_WFA_SRV\Parameters\Java

 

  • Find the multi-string value named Options, and change the -Xmx1536m default max to something bigger, like -Xmx3072m
  • Save
  • Restart WFA service