Subscribe

How to supress specific DFM alert

Hi Geniusses ,

I have frequent DFM alert alarming "not enough spare disks". I want only this alert to disable; however remain intact rest of the alerts. Can someone please suggest different ways of doing it?

Exact alert:

There are not enough spare disks.
||| /aggr0/plex0/rg0: Please add spare disks to any pool supporting block checksums with minimum size: Used 418000/856064000 (MB/blks). |||

Many thanks in advance....

VM

Re: How to supress specific DFM alert

HI Vaibhav,

Alert here you mean the event or the alarm. if its the event you cant suppress it. If its a alarm you can go and disable the alarm.

Re: How to supress specific DFM alert

Thanks Pradeep for time to read and respond to my query.

This is event not a alarm. Here is a complete details from notification e- mail.

 

An Error event at 10 Jun 06:08 SGT on Active/Active
Controller XYZ.dc.ABC.com:

 

Global Status: NonCritical; There are not enough spare disks. /aggr0_SAS/plex0/rg0: Please add spare disks to any pool supporting block checksums with minimum size: Used 418000/856064000 (MB/blks).

Also can you detail more as how alarm (DFM) is different than event. As much as DFM is concerned, mostly it is events like error, warning etc....

Thanks,

VM

Re: How to supress specific DFM alert

HI Vaibhav,

     This sounds like the filer is most likely triggering that event to DFM, and DFM is simply emailing it to you.  Check "options min_spare_count" and see what that is set to.  If you knowingly run with less spares than the value set in this, set it to the number of spares you keep. 

Be sure to take into account if you have multiple aggregates with multiple disk types that the minimum is set for the highest number of spares you get. For example if you have aggr0 and aggr1, and you keep two spares in aggr0 and one spare in aggr1, your spare count should be 2.

- Scott