Subscribe
Accepted Solution

Ignoring DFM Alerts

All,

Is it possible to ignore alerts for specific  objects(volumes) within Operations Manager. My customer has a number of  volumes in their environment and they would like to not be notified when  specific volumes generate alerts. In my case they do not want to be  notified when a particular volume is filled up.

Hope this makes sense.

Thanks in  advance for the help!

Re: Ignoring DFM Alerts

There may be a more elegant solution offered to this later, but here is one way.

1.  Use the "dfm eventtype" command line to lower the severity of the Volume Full event so that it is not forwarded to email or pagers as part of the Critical or Emergency eventtype severity levels.  This will remove alarms from all volumes (bear with me).

2.  Create a new group in OM to house all the volumes you want to be alarmed on.  If all the volumes on a given storage appliance should receive alarms, add the entire appliance as a group member.  The same is true for Aggregates.  This is a cumbersome solution if the volumes you care about are widely scatttered.  It is very easy to script a solution for this kind of problem if the volumes you want to be alarmed on have a consistent naming convention.  You could also easily automate the addition of new volumes to this group in the future, based on a scheduled script that matched the naming convention and automatically performed the group addition.

3.  Create a new alarm in OM which will catch the Volume Full event, but only for the newly created group and attach the appropriate paging and alarming to that new alarm.  You can attach pagers and email notificaitons to specific events for specific groups regardless of what severity they are (see step one).

Re: Ignoring DFM Alerts

Thank You Very Much! This is exactly what I needed!!!!!

Re: Ignoring DFM Alerts

Hi

Alerts/Alarms in dfm can only be configured at global or group level and not at individual object levels like Aggr A, volume B etc.

So either you can group these volumes and don’t create an alarm.(for this to work you shouldn’t have any alarms at global level)

Or easier way is to set the threshold value of this particular volume to higher value than the default of 80 and 90.

This can be done from both UI and cli .

From cli use the dfm volume set command to get the threshold name and values. And use dfm volume set <volumename-or-id> thresholdname=thresholdvalue.

From web UI go to the volume details page of the particular volume and on the left hand side Under Volume Tools click “ Edit Quota Settings <http://10.72.186.223:8080/dfm/edit/volume?object=54655&group=0> ” and chage the values.

Regards

adai