Subscribe

Java version for OCI 6.4.1

Hello,

I'm trying to find out if there is a particular Java update that works best with OCI 6.4.1.  I'm not sure if there is, because some of our users are experiencing issues, and the version of Java varies across workstations.  Some are still in Java 6 while others are Java 7, so it makes it a little hard to figure out why some are having a problem while others are not.  We plan to upgrade to 7.0 after the kinks are worked out, so in the meantime I need to have all users able to access the current interface.  Maybe it's not Java, but something else impacting the access?

Any thoughts or guidance would be much appreciated!

Thank you!

Re: Java version for OCI 6.4.1

Hey Julia,

As you may be aware, Oracle has been on a no-holds-barred warpath in fixing Java security issues. They are not all that concerned with breaking existing applications. OCI 6.4.2 and higher contain work for our Java client to work against Java 7u45 and higher. Java 7 update 51 I believe also had additional changes, but we got ahead of them with 6.4.2. There is no workaround possible for OCI 6.4.1 or earlier OCI versions

So, it may be the upgrading to OCI 6.4.3 or 7.0.0 is your best bet to allow the latest Java 7 versions to work with the OCI client

Matt

Re: Java version for OCI 6.4.1

Thanks for the prompt response!  It's just interesting that some folks are having no problems while others are.  I wasn't sure if there was a particular Java version or update that we shouldn't go past or could maybe help to remedy some of these issues.  We were planning to upgrade, but then 7.0 showed up and decided to wait so we weren't doing several updates in a short amount of time. 

Thanks again,

Julia