Subscribe

Maximum Fan-In Ratio to a secondary volume setting not working?

I setup the "Maximum Fan-In Ratio to a secondary volume" setting to 4 so that I can add multiple primary to a secondary volume.

I already have an existing snapvault relationship backing up all the contents of Profiler1 vol0 to DRfiler1. Now I want to add another primary volume from Profiler2 vol0. I edited my dataset to add another primary but it is telling me that I need to create another secondary volume.

What am I missing here?

Thanks,

Maico

Re: Maximum Fan-In Ratio to a secondary volume setting not working?

Hi Maico,

     Max fan-in ratio is only applicable to SV and QSM relationship which are qtree based. This options is not applicable to VSM relationships as they are volume  based. What kind of relationship are you doing ? Is it VSM or QSM or SV ?

Here is a brief write up on Fan-In ratio.

Protection Manager supports volume fan-in to allow multiple source volumes to go to a single secondary volume. If fan-in is desired, the NetApp best practice is to set the fan-in ratio to four. Fan-In is only applicable to QSM and SV relationship and not for VSM or OSSV relationships

  • Pros of Fan-In value higher than 1.
    1. Less Secondary Controllers.As you wont hit the controller limit of 500 volumes.
    2. Take an example of a 100 volumes each from 10 different primary Storage System need to be backed up to a single secondary Storage System. A secondary storage system would require 1000 volumes, yet the maximum supported volume count is 500 on FAS 3xxx or 6xxx series, with fewer on entry levels models. However, if capacity is the limiting factor rather than volumes, it may be preferable to keep fan-in at 1:1.
    3. More Dedupe Savings.
  • Dedupe operates in the scope of a volume. Greater storage efficiency may be obtained by increasing the fan-in ratio when primary volumes share common data.
    1. If there is plan to move towards ONTAP 8.0 7-Mode to provision 64 bit aggregates on the secondary controllers. If that’s the case they can easily have more than 25 secondary volumes on their 64-bit aggregates which could be a potential sweet spot for the Fan-in use case.
    2. Reduces the number of dedupe jobs, but it might increase the duration of these jobs.
    3. Simplifies the snapshot management, Reduces the number of Snapshots being created and deleted.
  • Cons of Fan-In values higher than 1
    1. Long running transfers.
      • When 4 primary volumes are backed up to 1 secondary volume and one of the four takes a longer time to complete the update, the creation of snapshot on the secondary volume is delayed as it can be taken only when all incoming relationships to the volume are completed
      • The NDMP session and the replication stream on the Storage System are held open by long running transfers.
      • There are chances of missing SLA with frequent updates such as every couple of hours
    2. Reduces the flexibility of migrating secondary volumes for space management, as it becomes more difficult to find aggregates with sufficient free space.
    3. Backing up multiple primary volumes to a single secondary volume increases the risk of hitting dedupe volume size limits. When we have dpDynamicSecondarySizing option enabled, Protection Manager won’t be able to grow the secondary volume beyond the dedupe-platform limit. Instead, it would provide a warning message in the job log and continue with the transfer. Hence, if the secondary volume doesn’t have enough space, then the transfer will fail.

Regards

adai

Re: Maximum Fan-In Ratio to a secondary volume setting not working?

Thanks Adai for the detailed explanation. I was performing a SV. I got it to work, I just had to wait for the change in setting to take into effect. I set it to four in Operations Manager.

Maico

Re: Maximum Fan-In Ratio to a secondary volume setting not working?

hello

I have the issue linked to fan-in ratio

but I can not find how to modify this parameter can some one help?

thanks