Subscribe

NAbox not able to upgrade

When I try to upgrade nabox from 2.3 to version 2.4b through the admin web site it gives the following error. Any ideas what might be causing it? I can open the tgz file and it does not seem to corrupted.

 

Cannot prepare for upgradeERROR Cannot move upgrade bundleERROR Cannot uncompress upgrade bundleERROR Bundle not recognized

Re: NAbox not able to upgrade

I went from 2.3 to 2.4.2 yesterday.  Pre-upgrade dashboards were fine. Post upgrade I run into alot of this....

 

2018-01-03_11-41-29.jpg

 

A lot of "internal server error" corner flags now.

Re: NAbox not able to upgrade

same here. Any Solution on this?

Re: NAbox not able to upgrade

So I worked with Yann on this one for a couple days.  I never broke through WHY the initial deployment of 2.4.2 would fail after 75% progress.  But as for the upgrade from version 2.3 to 2.4.2...

 

I was able to throw more vCPUs (4 vs the default 2) at the VM and I also learned that if you try to view ALL volumes while in the dashboard "NetApp Detail: Volume" the internal server error flags show up.  I never ran into this with previous versions of NABox but I'm fine knowing that if I select a handful of volumes AT MOST I can avoid the error condition.  Personally, I can work within that requirement.  Perhaps there is a total volume count that "breaks" the dashboard when hit - I typically drill down into a single volume when troubleshooting or trending anyway.

 

So as far as I can tell, this workaround gets me over the hump.

 

Greg

Re: NAbox not able to upgrade

Re: NAbox not able to upgrade

Any fix to this upgrade issue from 2.3 to 2.4 ?