Subscribe
Accepted Solution

NetApp-Harvest: Server returned HTTP Error

Hi all,

 

I have recently install Harvest 1.2.2 but get the following error when trying to poll for most of our 7mode controllers :

 

[PROD][root@parg3pharv001 netapp-harvest]# ./netapp-worker -poller n02sanp0002a
[2015-12-18 10:46:37] [NORMAL ] WORKER STARTED [Version: 1.2.2] [Conf: netapp-harvest.conf] [Poller: n02sanp0002a]
[2015-12-18 10:46:37] [WARNING] Started in foreground mode; messages to STDERR are redirected to the logfile and are not visible on the console.

 

[PROD][root@parg3pharv001 log]# tail -f n02sanp0002a_netapp-harvest.log
[2015-12-18 10:48:27] [WARNING] [sysinfo] Update of system-info cache DOT Version failed with reason: Server returned HTTP Error:
[2015-12-18 10:48:27] [WARNING] [main] system-info update failed; will try again in 10 seconds.
[2015-12-18 10:48:37] [WARNING] [sysinfo] Update of system-info cache DOT Version failed with reason: Server returned HTTP Error:
[2015-12-18 10:48:37] [WARNING] [main] system-info update failed; will try again in 10 seconds.

 

[PROD][root@parg3pharv001 log]# tail -f ntapprdmd1_netapp-harvest.log
[2015-12-18 10:50:00] [WARNING] [sysinfo] Update of system-info cache DOT Version failed with reason: Server returned HTTP Error:
[2015-12-18 10:50:00] [WARNING] [main] system-info update failed; will try again in 10 seconds.
[2015-12-18 10:50:10] [WARNING] [sysinfo] Update of system-info cache DOT Version failed with reason: Server returned HTTP Error:
[2015-12-18 10:50:10] [WARNING] [main] system-info update failed; will try again in 10 seconds.

....

 

I can't seem to find supporting information for this error? Any information would be great

 

Thanks

 

Jef

Re: NetApp-Harvest: Server returned HTTP Error

Hi @JF-Louvet

 

 

If TLS is not enabled you can get some vague empty errors like this.  Is TLS enabled?

netapp> options tls.enable on 

 

Cheers,
Chris Madden

Storage Architect, NetApp EMEA (and author of Harvest)

Blog: It all begins with data

 

P.S.  Please select “Options” and then “Accept as Solution” if this response answered your question so that others will find it easily!

 

Re: NetApp-Harvest: Server returned HTTP Error

LAck of attention. Smiley Frustrated

 

Many thanks for your help  Smiley Happy

Re: NetApp-Harvest: Server returned HTTP Error

Ran into this myself, but it's an older version of ONTAP with no tls.enable option (8.0.3P4). Will Harvest not be able to run against those controllers?

Re: NetApp-Harvest: Server returned HTTP Error

[ Edited ]

H @Adam-Gross

 

Because vulnerabilities were discovered in SSL v3 you can no longer guarantee communications using it are secure.  As a result the SDK was also adapted to require TLS and I added the instructions to enable TLS in Data ONTAP.  If you have controllers that don't support TLS and you can't or don't want to upgrade them to a release that does, as a workaround you could use an older version of the SDK (I suggest 5.3) that still non TLS connections.

 

Here are the steps:

1) Download http://mysupport.netapp.com/NOW/download/software/nmsdk/5.3/ from the support site and copy into /tmp.

 

2) Extract it:

cd /tmp

unzip netapp-manageability-sdk-5.3.zip netapp-manageability-sdk-5.3/lib/perl/NetApp/*

 

3) Stop the poller

/opt/netapp-harvest/netapp-manager -stop

 

4) Rename current lib

mv /opt/netapp-harvest/lib /opt/netapp-harvest/lib-old

5) Copy 5.3 lib in place

mv netapp-manageability-sdk-5.3/lib/perl/NetApp/* /opt/netapp-harvest/lib

6) Start poller

/opt/netapp-harvest/netapp-manager -start

 

Please post if this allows collection or not, and kudos if it is indeed a solution for you.

 

Cheers,
Chris Madden

Storage Architect, NetApp EMEA (and author of Harvest)

Blog: It all begins with data

 

If this post resolved your issue, please help others by selecting ACCEPT AS SOLUTION or adding a KUDO