Subscribe
Accepted Solution

Netapp-Harvest: Undefined subroutine error when I start a poller

[ Edited ]

I installed Harvest according to the manuals and when I start a pooler to one of our Netapp Clusters it stops after short time with this error:

 

[2015-12-22 11:38:32] [NORMAL ] WORKER STARTED [Version: 1.2.2] [Conf: netapp-harvest.conf] [Poller: NCL01-ATKLA]
[2015-12-22 11:38:32] [WARNING] Started in foreground mode; messages to STDERR are redirected to the logfile and are not visible on the console.
[2015-12-22 11:38:32] [NORMAL ] [main] Poller will monitor a [FILER] at [NCL01-ATKLA.company.com:443]
[2015-12-22 11:38:32] [NORMAL ] [main] Poller will use [password] authentication with username [svc_harvest] and password [**********]
Undefined subroutine &Net::SSLeay::load_error_strings called at /opt/netapp-harvest/lib/NaServer.pm line 385.

 

Can someone please point me to the right direction?

 

Re: Netapp-Harvest: Undefined subroutine error when I start a poller

Do you have the Net::SSLeay module installed for your Perl? Here is one way to check for installed modules.

 

Andrew

If this post resolved your issue, please help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: Netapp-Harvest: Undefined subroutine error when I start a poller

[ Edited ]

Hi @InfoSys00

 

 

It sounds like you don't have the Net::SSLeay module on your system which is a dependency.

 

Run this:

 

perl -e "use Net::SSLeay;"

 

 

 

If you get a Can't locate error then you must have skipped or had an error when installing the Perl prerequisite modules listed on page 8 of the Harvest installation guide.  Basically do the sudo yum install or sudo apt-get install step again from the guide and verify all are installed without error.

 

Cheers,
Chris Madden

Storage Architect, NetApp EMEA (and author of Harvest)

Blog: It all begins with data

 

P.S.  Please select “Options” and then “Accept as Solution” if this response answered your question so that others will find it easily!