Subscribe

Netapp Harvest & OCUM Communication Issue - cluster-iter failed to read API Response

Hi,

 

I am trying to connect a new Netapp Harvest install with our pretty new OCUM 6.4P1 instance and they are able to see and do some basic communications (Ping/SSH,etc) but I am getting the following error whenever I try to configure the Harvest poller to gather capacity stats.

 

[2016-10-17 17:57:41] [WARNING] [sysinfo] cluster-iter failed with reason: Timeout. Could not read API response.
[2016-10-17 17:57:41] [WARNING] [main] system-info update failed; will try again in 10 seconds.

 

I have verified the auth creds are correct b/c I get a different error when I use an incorrect password.  Could it be a load/response time issue with the OCUM server?  It has near the recommended limit of nodes/clusters configured on it.

 

Any help to fix this issue would be appreciated.

 

Thanks,

McGee

Re: Netapp Harvest & OCUM Communication Issue - cluster-iter failed to read API Response

Hi @McGeeOlson

 

My experience is this sort of 'vague' error is usually provided by the intermediate Perl SSL libraries when some part of the SSL handshake and verification goes wrong.

 

In this post we found an incompatibility between a given host OS level and OCUM.  Maybe you can try some of the troubleshooting steps in that post and see if you get closer to root cause?

 

Feel free to post interesting findings and we can give some advice on next steps.

 

Cheers,
Chris Madden

Solution Architect - 3rd Platform - Systems Engineering NetApp EMEA (and author of Harvest)

Blog: It all begins with data

 

If this post resolved your issue, please help others by selecting ACCEPT AS SOLUTION or adding a KUDO or both!