Subscribe
Accepted Solution

Netapp-Harvest couldn't connect to UCUM

Hello!

I try to configure OCUM capacity metrics in netapp-harvest, but unfortunately, I have some warnings in log and capacity utilization valule didn't show on netapp's grafana dashboards.

My netapp-harvest.conf is:

 

##
## Default reserved section
##

[default]
#====== Graphite server setup defaults ========================================
graphite_enabled = 1
graphite_server = 10.64.0.9
graphite_port = 2003
graphite_proto = tcp
normalized_xfer = mb_per_sec
normalized_time = millisec
graphite_root = default
graphite_meta_metrics_root = default

#====== Polled host setup default ============================================
# host_type = FILER
# host_port = 443
# host_enabled = 1

##
## Monitored host examples - Use one section like the below for each monitored host
##

#====== 7DOT (node) or cDOT (cluster LIF) for performance info ================
#
[fas-clu3-ds]
host_type = FILER
host_port = 443
host_enabled = 1
template = default
data_update_freq = 60
ntap_autosupport = 0
latency_io_reqd = 10
hostname = 10.66.16.5
site = MSK
display_name = FAS-CLU-DS3
auth_type = password
username = harvest
password = **

#====== OnCommand Unified Manager (OCUM) for cDOT capacity info ===============

[srv-oncmdum01]
hostname = 10.64.0.11

site = MSK
host_type = OCUM
data_update_freq = 900
normalized_xfer = mb_per_sec
template = ocum-opm-hierarchy.conf
graphite_root = netapp-capacity.Clusters.{display_name}
graphite_meta_metrics_root = netapp-capacity-poller.srv-oncmdum01
auth_type = password
username = harvest
password = **

 

All of the cDOT perf metrics is collecting normal. In log file for srv-oncmdum01 poller are next warnings (every 10 seconds):

 

[2016-02-17 01:05:47] [WARNING] [sysinfo] system-about API failed with reason: in Zapi::invoke, cannot connect to socket
[2016-02-17 01:05:47] [WARNING] [main] system-info update failed; will try again in 10 seconds.
[2016-02-17 01:05:57] [WARNING] [sysinfo] system-about API failed with reason: in Zapi::invoke, cannot connect to socket
[2016-02-17 01:05:57] [WARNING] [main] system-info update failed; will try again in 10 seconds.

 

Where I made a mistake?

Re: Netapp-Harvest couldn't connect to UCUM

[ Edited ]

Hi @koliama,

 

I see a couple of things you probably don't want/need in the config.  I just edited the default conf with your values and come up with this:

 

 

##
## Configuration file for NetApp Harvest
##
## Create a section header and then populate with key/value parameters
## for each system to monitor. Lines can be commented out by preceding them
## with a hash symbol ('#'). Values in all capitals should be replaced with
## your values, all other values can be left as-is to use defaults
##
## There are two reserved section names:
## [global] - Global key/value pairs for installation
## [default] - Any key/value pairs specified here will be the default
## value for a poller should it not be listed in a poller section.
##

##
## Global reserved section
##

[global]
grafana_api_key = INSERT_LONG_KEY_HERE
grafana_url = INSERT_URL_OF_GRAFANA_WEB_INTERFACE_HERE
grafana_dl_tag =

##
## Default reserved section
##

[default]
#====== Graphite server setup defaults ========================================
graphite_enabled = 1
graphite_server = 10.64.0.9
graphite_port = 2003
graphite_proto = tcp
normalized_xfer = mb_per_sec
normalized_time = millisec
graphite_root = default
graphite_meta_metrics_root = default

#====== Polled host setup defaults ============================================
host_type = FILER
host_port = 443
host_enabled = 1
template = default
data_update_freq = 60
ntap_autosupport = 0
latency_io_reqd = 10
auth_type = password
username = INSERT_USERNAME_HERE
password = INSERT_PASSWORD_HERE

##
## Monitored host examples - Use one section like the below for each monitored host
##

#====== 7DOT (node) or cDOT (cluster LIF) for performance info ================
#
[fas-clu3-ds]
hostname = 10.66.16.5
site = MSK

#====== OnCommand Unified Manager (OCUM) for cDOT capacity info ===============
#
[srv-oncmdum01]
hostname = 10.64.0.11
site = MSK
host_type = OCUM
data_update_freq = 900
normalized_xfer = gb_per_sec

username = INSERT_USERNAME_HERE
password = INSERT_PASSWORD_HERE

 

You just need to update username, password, and grafana info (all the things with INSERT_SOMETHING_IN_CAPITAL_LETTERS) and you should be ok.  Maybe try with the udpated conf file and see how that goes.  If you still get that same error it indicates the poller cannot communicate with 10.64.0.11 on port 443.  But your conf was a bit jumbled so maybe by replacing it with the above you will fix your issue.

 

Cheers,
Chris Madden

Storage Architect, NetApp EMEA (and author of Harvest)

Blog: It all begins with data

 

P.S.  Please select “Options” and then “Accept as Solution” if this response answered your question so that others will find it easily!

 

Re: Netapp-Harvest couldn't connect to UCUM

Hi Chris!

Thank you very match. With your config Harvest connect to OCUM without problem

 

[2016-02-18 18:53:43] [NORMAL ] [main] Collection of system info from [10.64.0.11] running [6.3] successful.
[2016-02-18 18:53:43] [NORMAL ] [main] Using best-fit collection template: [ocum-6.3.0.conf]