Subscribe
Accepted Solution

Notify on: "Workflow excecution failed" reporting failures that don't exist

Hello,

     I am trying to get one of the more influential internal customers here to start using WFA, but they have notify on job failure set and WFA is emailing for failures that are not actually occurring within the job.  This is set to replace a homebrew script, with SSH admin keys on all our frames, that allows customers to do one time snapmirror copies.  I fully realize that flexclones would do this far more effectively, but the customer has shot flexclones down, and done it quite hard.

Is there something that I can adjust to stop these false alert emails from being sent?

Re: Notify on: "Workflow excecution failed" reporting failures that don't exist

Your .dar version shows that your WFA is 2.1. Is this correct?

This is a known issue with WFA2.1 that a false failure notification in SNMP and email gets sent when workflow is having a command of type "Wait for Condition". Your workflow has a command "Wait for VSM" of such type and this is the one causing the false notification.

This bug has been fixed in WFA2.2 GA.So please upgrade.

sinhaa

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: Notify on: "Workflow excecution failed" reporting failures that don't exist

Hi Scott,

     As rightly pointed out by Sinhaa, its a known issue fixed in WFA 2.2GA release.

Take a look at this bug for more details on the same 802745.

Regards

adai

Re: Notify on: "Workflow excecution failed" reporting failures that don't exist

Thank you,

     I am indeed using 2.1, I will start the discussions with the customers today about getting a maintenance window.

- Scott