Subscribe
Accepted Solution

OCI 7.1 HyperV WMI DataSource problem

Hi,

 

I would like to ask for an advice, I have no more ideas what to try...

I have a POC at customer, want to monitor HyperV with performances (added in last version). HyperV WMI Data Source reports an error when trying to get inventory:

Error retrieving data: com.onaro.sanscreen.acquisition.datasource.microsoft_hyperv.transport.WmiCommandException: Invalid XSL format (or) file name.

 

At the beginning the same problem was with command line call of WMIC commands (nicely described in documentation of data source). Then I have changed LOCALE settings on OCI server to English (US). WMIC call from command line now works properly and returns values, OCI still reports the same error. I tried to restart the server (windows first help...), no effect. I also tried to copy XSL files from win\system32\wbem\en-US to win\sysWOW64\wbem, what is an advice on many forums. Still no effect.

 

The most interesting thing is that I'm running OCI (the same version including same patches) on another POC, the LOCALE settings of OCI server is the same, even the OS version (W2K8 R2) and everything works fine. Does OCI remember the LOCALE settings from the time of instalation? Where can be the problem if command line WMI calls do work?

 

Thanks for any help in advance!

 

BR, Rostislav

 

Re: OCI 7.1 HyperV WMI DataSource problem

Hey Rostislav,

 

I am pretty sure that we think we should have solved all those .xsl file issues automatically - at least that was our intent. Basically, there is some weird WMI stuff Microsoft does from an internationalization perspective of certain versions of Windows.

 

I'd have to wonder if there is a chance in the other POC, we got a datasource patch deployed that resolved this

 

I am on vacation, but my peer in Germany gerhard dot hotz at netapp dot com could work with you to determine if this is a known issue solved with a patch, or something we need to fix.

 

Thanks,

 

Matt

Re: OCI 7.1 HyperV WMI DataSource problem

Hi Rostislav,

Can you send me the recordings? Also, are you sure this is a hyper-v node?

Re: OCI 7.1 HyperV WMI DataSource problem

Hi Gerhard,

 

while reading your replies I got an idea - and found the problem and also solution... There is really a problem with locale settings - customer has "sl-SI" (slovenian) settings and WMI call don't work with .XSL formatting. When I changed locale to en-US, I had no problems with WMI calls from command line. BUT I forgot the most important thing - OCI by default runs under LocalSystem account and, of course, it stayed with the previous locale - si-SI - that's why OCI was not working and report XSL problems. Unfortunately I'm not windows freek (I grew up with linux), I should know that these settings are only for local admin user and not for OCI system account... :-(

So I have changed regional settings to en-US for all accounts (control panel-regional settings, tab Adminstrative - copy settings), rebooted server and now IT WORKS! :-)

 

I have a phylosofical question - what if I cannot change the locale settings (because of any reason on customer's side) - what to do then? I'm sure you can reproduce XSL error by settings locale on OCI server to sl-SI, maybe also on some other eastern european...

 

Thanks a lot for previous help! It's much easier to find "solution" like this if you know, what's going on in the background.

 

Regards,

Rostislav

Re: OCI 7.1 HyperV WMI DataSource problem

Hi Rostislav,

 

good work. Thanks for posting it here.

Basically this is an issue on WMI level. You can take the commands the hyper-v data source is running 1:1 and run it on the command prompt. If there is an issue with the regional settings, you'll get the same error message on the CLI. While we're trying to make it as easy as possible for our customers, we can only do that when it comes to issues on OS level or with 3rd party software by documenting these and their potential solutions as good as we can. Part of it is this forum. So, thanks again for your post.

 

Kind regards,

Gerhard