Accepted Solution

OCI 7 Datasource exclude option

Have some HDS arrays attached to a HDvM instance which are waiting for decommissioning and we no longer need to monitor but I've tried placing excludes in the Datasource config both on Array name and IP address(es) but nothing appears to have changed.  Not sure if I'm then meant to delete the arrays from OCI console or they are meant to show as offline so I can then delete... they still appear in the Web console under the datasource after the excludes are in place so I'm assuming it's not working so well ... ??

Re: OCI 7 Datasource exclude option

Are you running OCI 7.0.0 or 7.0.1?

On 7.0.0 and earlier, you have to use a fairly cryptic syntax for HDS / HP CommandView AE exclusions.

For HDS arrays, use the following:


For example:


On 7.0.1, I believe this has been enhanced to be easier to use - I will follow up to this thread when I dig up the details of the enhancement

Re: OCI 7 Datasource exclude option


So it worked for one polling cycle... arrays showed as offline or removed and then next polling cycle they are back   I've comma separated the devices in the list so not sure if that's my issue?

Re: OCI 7 Datasource exclude option

Any chance you have duplicate datasources discovering these arrays?

On my 7.0.1 lab box, I confirm the traditional (painful) exclusion syntax, and the now supported serial number syntax works


That excludes 2 arrays. I have polled the datasource multiple times, and the exclusion consistently works

Re: OCI 7 Datasource exclude option

Ok sorted thanks... issue was I'd left a space between each of the devices so ARRAY.AMS500.1234, ARRAY.AMS500.5678

All sorted thanks