Subscribe

OCI - Failed to backup DWH (Cognos problems ?)

Hello,

 

we are using OCI 7.2.1 Build 7.

 

We often have issues with collecting performance data or accessing the DWH server or reporting. Error messages are similar to these: (HTTP Status 404 - /dwh/ - The requested resource (/dwh/) is not available. (JBoss Web/3.0.0-CR2))

 

 

We found, that the directory D: \ SANscreen \ SANscreen \ cognos \ c10_64 \ bin is completely full of dumps with files "BlBusTKServerMain_seh_nnnn_nnnn" between 196 MB up to 600 MB and there is no more space left on device.  (Why these dumps arise, unfortunately could not be determined yet.)

After deleting the dumps, everthings works fine again, normally.

 

Now we can't get a Backup of the DWH: "Failed to backup DWH: Failed to connect to reporting server, server might be down. Confirm reporting server availability and try again."  Also a connection to the reporting is no longer possible.

 

DWH and Insight Server are working. Services

- SANscreen Server

- MySQL

- IBM Cognos Content Database

are running.

 

Service "IBM Cognos" has no status. Starting the service manuall we got : "The IBM Cognos service on Local Computer started and stopped. SOme services stop automatically if they are not in use by other services or programs".

 

 

Any idea

 

Thanks a lot

 

Michael

 

 

 

 

 

 

Re: OCI - Failed to backup DWH (Cognos problems ?)

Hi,

 

The installation of external Java applications, upgrades, or server patches on OCI/DWH server can cause the deletion of the Javasoft registry keys resulting in issues such as these.

 

Perform the following steps:


1. Run regedit.exe and check if the keys exist in HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Prefs\com\netapp\sanscreen\reporting
2. If the following entries do not exist or are not specified, create them:
    dispatcher_url 'http:\INSERT_HOST_NAME_HERE/p2pd/servlet/dispatch" portal_url "http:\INSERT_HOST_NAME_HERE/reporting'

 

Hope this helps.

 

Thanks

 

 

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: OCI - Failed to backup DWH (Cognos problems ?)

We saw this issue a few times on OCI 7.1.x, but I am not aware of us seeing this on 7.2.x

 

Try this:

 

RDP to the OCI DWH

 

I am pretty sure that OCI 7.2.x is always Cognos 10.2.2 or higher.

 

As such, follow the 10.2.2 steps here:

 

http://www-01.ibm.com/support/docview.wss?uid=swg21698578

 

Matt

 

Re: OCI - Failed to backup DWH (Cognos problems ?)

Hi hariprak,

 
our value is : https:\\asocdw01.stadtdo.de:9300/p2pd/servlet/dispatch. - I think, this will be correct.
 
Thanks
 
Michael
 

Re: OCI - Failed to backup DWH (Cognos problems ?)

Hello Matt,

 

I have proceeded as described by you.

 

Steps for IBM Cognos 10.2.2:

  1. Stop the Cognos environment.
  2. Go to the ..\data directory of the IBM Cognos installation directory.
  3. Check for a file, with a similar file name like C260M3A64P_cognos10SYSTEM_G21
  4. Make a backup of this file and remove it from the ..\data directory.
  5. Repeat step 3 and 4 for all dispatchers configured with IBM Cognos Query Service.
  6. Start the Cognos environment.

Unfortunately without success.

 

I've already rebootet the system; nothing.

 

The "IBM Cognos"-Service becomes always the status "Stopped".  ("The IBM Cognos service on Local Computer started and stopped. Some services stop automatically if they are not in use by other services or programs.")

 

Nevertheless, thanks a lot.

 

Michael

 

Re: OCI - Failed to backup DWH (Cognos problems ?)

Hello,

 

The backup problem has now been solved by NetApp support - however.

The problems with the dumps persist, NetApp support continues to search for a solution.

 

Best regards

 

Michael

Re: OCI - Failed to backup DWH (Cognos problems ?)

Hey Michael,

 

I was in Vienna midweek, last week (not the one with coffee and Sacher Torte, the one in Virginia). Sorry for the delay.

 

The dumps issue sounds vaguely familiar*, but I thought we knew of a workaround. Can you PM me the case number?

 

http://www-01.ibm.com/support/docview.wss?uid=swg21698578

 

That is the issue I am familiar with - at the bottom, there is another link, which makes it seem that it is an IBM JRE problem,

 

OCI 7.2.3's Cognos deployment ships a newer IBM Java than is described as containing the IBM JRE fix. I don't have a 7.2.2 DWH handy to know if that contains the required IM JRE version

 

Matt

Re: OCI - Failed to backup DWH (Cognos problems ?)

Hi Matt,

 

 

thank you for your info.

The problem is covered in Case # 2006578161. At the moment everything works fine, except for the constantly created dumps, which only make problems when the drive would be full. So I just delete them every few days.

 

I have the NetApp Support already suggested to update OCI to the latest version. I'm still waiting for the answer.

 

Best regards

 

Michael