Subscribe

OCI Report with embedded Images

Hi,

 

We have changed the certifcates on OCI Reporting Server to our own certificates, but when a report with embedded images is running , the image create a certificat error ( non trusted )

The url to image https://Server:9300/p2pd/samples/image use the cert from CAMUSER ( cognos access manager ).

How can I change this certificate to our Certificate ? or

How can I solve this ?

 

thanks

Michael

 

Re: OCI Report with embedded Images

Hi Michael,

could you try to import that certificate in "..\sanscreen\cognos\c10_64\bin64\jre\7.0\lib\security\cacerts" and "..\sanscreen\cognos\c10_64\bin\jre\7.0\lib\security\cacerts". Restart the Cognos service and let us know the behavior. thank you.

Re: OCI Report with embedded Images

Hi Hotz,

 

Thank you Hotz

I've tried to do so but unfortunately without success, the Image returns Cert. error

But I`ve found this http://www.tm1forum.com/viewtopic.php?t=10277    i think that is the same Problem, but I dont know

what OCI used to execute a Report.

The Jboss is used for the session to report studio, start report and than ..... Jboss ... or Tomcat what use OCI ?

I see only the embedded Image used a Cert from CMUSER.

 

The same Problem is to insert a Image in a Report, where should be the image in ..\sanscreen\cognos\..\webapps\p2pd\samples or \webcontent\images ?

and where is the Config that you can Browsing the Image Directory from the Report Studio, in OCI 6.x it was the httpd.conf , but in OCI 7 ?

 

thanks

Michael