Subscribe
Accepted Solution

OCPM vmware appliance 2.0.0P4 Update with iso 2.1.0P1 failed

[ Edited ]

Bildschirmfoto 2017-02-06 um 07.44.11.jpg

 

if i try the update via diag user, i can see that the update script tries to stop mysql.server but the service is named mysql.

then i copied the service to the new name mysql.server but this did not help at all it failed again and hangs during update !!

 

Pasted Graphic 2.tiff

 

 

How to get a working update iso for 2.0.0P4 to 2.1.0P1 ??!

Re: OCPM vmware appliance 2.0.0P4 Update with iso 2.1.0P1 failed

Capture a Support Bundle (maint console) that contains logs that cover these upgrade attempts (i.e. capture the SB now, don't wait).  An ASUP should also be triggered from this instance.  

 

Help -> About to copy application name, version, and system id (the text can be copied from this dialog box).

 

Open a support case and add the Help -> About text and the exact steps executed and what workaround were tried.  When the case numberm is known, upload the Support Bundle to this case number for investigation.  

Re: OCPM vmware appliance 2.0.0P4 Update with iso 2.1.0P1 failed

hi,

 

these vmware appliances are not a special installation, these are only test systems to first check what we might see on an update. We do NOT want to waste our prod systems with such trial end error.

 

So the vmware Appliance 2.0.0.P4 was downloaded from netapp now software, base configured to reach the website and run the basic config.

After this, without having collected additional data and so on (Labor environment) i tried to update the appliance to 2.1.0P1 withe the update iso file downloaded from netapp now software.

 

If you really want to see YOUR update.sh failing on update just try these small steps, as these are netapp appliances this should work from scratch.

As long as YOUR script for update to 2.1.0P1 definitely tries to shutdown a service mysql.server which is not instaled on 2.0.0P4 this might be a generel issue, not based on any customer installation !?

 

thanks for your idea, maybe i should crash my prod environment and after this i will create an Support Call, but at the Moment i do not want to get the risc of loss these service in weeks of analysis.

 

kind regards

 

CP

 

PS: i thought using an apliance will definitely make my work easier....Smiley Sad

Re: OCPM vmware appliance 2.0.0P4 Update with iso 2.1.0P1 failed

I appreciate that this can be frustrating for you when a failure occurs. 

 

There was no suggestion to run any upgrade on a production environment.  The type of environment was not specified in the OP.

 

The suggestion to capture troubleshooting information and open a case was to work towards a resolution of the problem in your estate as you have already experience the problem and have logs of the failure.  If your production environment upgrade will be from/to the same releases stated, it is critical that a solution is found to not impact production.

 

If you do open a case, please PM the case number.

 

Thanks.

 

 

Re: OCPM vmware appliance 2.0.0P4 Update with iso 2.1.0P1 failed

[ Edited ]

as this looks more like a basic problem of your update iso i thought you can address this in general to your coding guys.

okay i will setup a new environment in my lab and create a case to analyze and to help you getting more quality in the update.sh.

at the moment this is not a prio 1 because of the update of our environment is canceled (risc seen in lab)

 

regards

CP

 

Case created i have send you the Case Id

Re: OCPM vmware appliance 2.0.0P4 Update with iso 2.1.0P1 failed

[ Edited ]

my problem is, i cannot get the whole support bundle through the mail servers which i haveto use, there is only the body.

okay got the hint 

https://kb.netapp.com/support/s/article/ka31A0000000k6tQAA/how-to-generate-a-support-bundle-in-oncommand-unified-manager-6-x-and-7-x-vapp-ova?language...

sftp is working now

support bundle is uploaded now 

Re: OCPM vmware appliance 2.0.0P4 Update with iso 2.1.0P1 failed

update to 2.1.0P2 did it, so do NOT Update from 2.0.0P4 to 2.1.0P1 because it is NOT possible Smiley Wink

Bildschirmfoto 2017-02-10 um 13.19.21.jpg