Subscribe

OCUM 6.3 custom reports using BIRT - snapshot policy not exist in Volume Table

Since OnCommand Report has been dismissed, I'm trying to create reports directly from OCUM DB and using Eclipse/BIRT.

I used BIRT in the past too, so I don't have problems to create simple reports from DB and Odbc.

 

I noticed that one of the embedded views (not reports) can show you all the volume details and in particular the snapshot policies applied to the volume/s.

I tried to see if this is an information registered in the DB, so simply Querying the DB via BIRT and it doesn't exist, or I'm unable to find it.

This information would be very useful for me, in order to create a custom report with all the information related to the volumes into the cluster.

And this is the question: how is retrieved that information in OCUM ? I know that it's a "field" in the volume via cli, but how is possible as that information has not been saved in the DB?

 

And,

is it possible to query the historical data or data within a time interval in order to create a report/graph per time as like as the views in OCUM?

 

Many thanks

 

 

Re: OCUM 6.3 custom reports using BIRT - snapshot policy not exist in Volume Table

Hi Mark -

 

With respect to Volume/Snapshot policy - you are correct that the data is present.  The publically available tables/views includes the "volume" table which has a "snapshotPolicyId" that links to the matching "objid" entry in the "snapshot_policy" table.

 

Almost everything in OCUM links together this way.

 

 

I hope this helps you.

 

Bob Greenwald

Lead Storage Engineer | Consilio, LLC

NCIE SAN Clustered, Data Protection

 

 

Kudos and accepted solutions are always appreciated.

 

 

 

 

Re: OCUM 6.3 custom reports using BIRT - snapshot policy not exist in Volume Table

Hi Bob,

 

actually I tried to find them before posting the question. I'm doing the same for node,svm etc, so joining the volume ids with the relative tables.

But that snapshotpolicyid doesn't exist or I'm unable to find it, so like as the snapshot table...

This Unified Manager (not core package) is an old OVA which has been upgraded to 6.3.

I didn't install the OS version yet...it might be the solution ?!