Subscribe
Accepted Solution

OCUM 6.4 on RHEL install fails with a postinstall scriptlet failure for ocie-serverbase package

[ Edited ]

Hi Guys,

 

I'm attempting to install OCUM 6.4P1 on RHEL 6.7.

 

The pre_install_check.sh script executes without any issues. My host meets the requirements shown in the Installation and Setup Guide. I can install OCUM 6.3 without any issues.

 

My problem happens when I get to installation of the ocie-serverbase-1.3.0-2016.05.2052.x86_64 package. The postinstall script fails with an exit status 255, which corresponds to an "exit -1" in the postinstall script.

 

 

Actual error message:

warning: %post(ocie-serverbase-1.3.0-2016.05.2052.x86_64) scriptlet failed, exit status 255

Non-fatal POSTIN scriptlet failure in rpm package ocie-serverbase-1.3.0-2016.05.2052.x86_64

 

FAILURE: ocie-serverbase package installed, but in corrupt state.

 

 

I have attached the postinstall script which I extracted from the rpm.

 

Has anyone else experienced a similar problem?

 

Cheers, Renton.

Re: OCUM 6.4 on RHEL install fails with a postinstall scriptlet failure for ocie-serverbase package

Ok, managed to figure this one out myself. It was permissions on /opt/netapp/data

 

I had 755 on /opt and /opt/netapp/data, but had 700 on /opt/netapp.

 

Set permissions to 755 on /opt/netapp and then all packages installed correctly :-)

Re: OCUM 6.4 on RHEL install fails with a postinstall scriptlet failure for ocie-serverbase package

Thanks a lot. Will check them