Subscribe
Accepted Solution

OPM 2.0 Install issues

[ Edited ]

I am having issues trying to get OPM 2.0 installed on my RHEL 6.5 (Santiago) 64 bit server.

 

--> Finished Dependency Resolution
Error: Package: MySQL-client-5.6.26-1.el7.x86_64 (/MySQL-client-5.6.26-1.el7.x86_64)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: ocie-serverbase-1.3.0-2015.08.1013.x86_64 (/ocie-serverbase-1.3.0-2015.08.1013.x86_64)
           Requires: java-1.8.0-oracle >= 1.8.0.51
Error: Package: MySQL-server-5.6.26-1.el7.x86_64 (/MySQL-server-5.6.26-1.el7.x86_64)
           Requires: libc.so.6(GLIBC_2.17)(64bit)
Error: Package: MySQL-client-5.6.26-1.el7.x86_64 (/MySQL-client-5.6.26-1.el7.x86_64)
           Requires: libc.so.6(GLIBC_2.17)(64bit)
Error: Package: MySQL-server-5.6.26-1.el7.x86_64 (/MySQL-server-5.6.26-1.el7.x86_64)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: MySQL-server-5.6.26-1.el7.x86_64 (/MySQL-server-5.6.26-1.el7.x86_64)
           Requires: libc.so.6(GLIBC_2.16)(64bit)
Error: Package: MySQL-server-5.6.26-1.el7.x86_64 (/MySQL-server-5.6.26-1.el7.x86_64)
           Requires: libc.so.6(GLIBC_2.15)(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

 

Here is what I have installed:

 

compat-glibc.x86_64                   1:2.5-46.2           @rhel-x86_64-server-6
compat-glibc-headers.x86_64           1:2.5-46.2           @rhel-x86_64-server-6
glibc.i686                            2.12-1.149.el6_6.5   @/glibc-2.12-1.149.el6_6.5.i686
glibc.x86_64                          2.12-1.149.el6_6.5   @/glibc-2.12-1.149.el6_6.5.x86_64
glibc-common.x86_64                   2.12-1.149.el6_6.5   @/glibc-common-2.12-1.149.el6_6.5.x86_64
glibc-devel.i686                      2.12-1.149.el6_6.5   @/glibc-devel-2.12-1.149.el6_6.5.i686
glibc-devel.x86_64                    2.12-1.149.el6_6.5   @/glibc-devel-2.12-1.149.el6_6.5.x86_64
glibc-headers.x86_64                  2.12-1.149.el6_6.5   @/glibc-headers-2.12-1.149.el6_6.5.x86_64

Re: OPM 2.0 Install issues

At a glance, looks like you're using the wrong MySql version (el7), instead (el6).

The 3rd path package has two versions in OPM 2.0 download from my recall, one for Redhat 6 and one for 7

Re: OPM 2.0 Install issues

Okay.  I feel really stupid right about now.  My mind must still be in holiday mode.  You are correct.  I downloaded the rhel6 version.

Re: OPM 2.0 Install issues

Had similar situation when mucking around on different version of rhel Smiley Happy