Subscribe
Accepted Solution

OnCommand Core 5.0 - perfdata directory setting problem!

I've upgraded the DFM 4.0.2 install to OnCommand Core 5.0.

The Upgrade did not keep the (non default) perfdata directory location and reseted it back to C:\Progr....

I've changed it to our location of F:\perfdata, stopped and started the server process and it was OK.

Now I've found that after a server reboot it is back to C:\Progra....

Any idea how to make this permanent?

Peter

OnCommand Core 5.0 - perfdata directory setting problem!

>>I've changed it to our location of F:\perfdata

[In case you have not used 'dfm options set perfArchiveDir="F:\perfdata", then you can use this. If this still doesnot resolve issue, you can try '

dfm datastore setup (with -p perfArchiveDir option)' again].

If there is a open BURT for this issue, i will let you know.

OnCommand Core 5.0 - perfdata directory setting problem!

I've used "dfm options set perfArchiveDir="F:\perfdata"...

Just tried the other command and it is still the same, reset back to C:\Program... after the reboot.

Peter

OnCommand Core 5.0 - perfdata directory setting problem!

Any more ideas? Please?

OnCommand Core 5.0 - perfdata directory setting problem!

Hey there

The server had to be rebooted again (hotfixes) and the setting was back to C:.....

Any news on a fix for this?

Thanks,

Peter

Re: OnCommand Core 5.0 - perfdata directory setting problem!

My workaround after every server reboot…..

dfm datastore setup -n -p D:\NetApp\DataFabricManager\perfdata

H:\>dfm backup diag

Sybase Data Directory:      D:\NetApp\DataFabricManager\data/

Sybase Log Directory :      D:\NetApp\DataFabricManager\data/

Performance Data Directory: C:/Program Files/NetApp/DataFabric Manager/DFM/perfdata

Script-plugins Directory:   D:\NetApp\DataFabricManager\script-plugins

Reports Archive Directory:  D:\NetApp\DataFabricManager\reports\

Plugins Directory:          D:\NetApp\DataFabricManager\plugins

Database Hosting System:    localhost

SnapDrive Installed:        Yes

SnapDrive Version:          6.3.1.5028

SnapDrive Status:           Passed(Data not present on LUN)

Volume Snapshot Status:     NA

Backup Destination:         D:\NetApp\DataFabricManager\data\

Number of backups possible: 80

Backup Retention Count:     10

Allowed Backup Type:        Archive (ndb)

H:\>dfm datastore setup -n -p D:\NetApp\DataFabricManager\perfdata

Stopping all services and jobs...

Starting sql service...

Changed perfArchiveDir to D:\NetApp\DataFabricManager\perfdata.

No database upgrade is necessary.

Updating database cache triggers.

Redefining SQL Views ...

Defining SQL debug procedures ...

Defining metadata accessors ...

Starting services...

Completed data setup.

H:\>dfm backup diag

Sybase Data Directory:      D:\NetApp\DataFabricManager\data/

Sybase Log Directory :      D:\NetApp\DataFabricManager\data/

Performance Data Directory: D:\NetApp\DataFabricManager\perfdata

Script-plugins Directory:   D:\NetApp\DataFabricManager\script-plugins

Reports Archive Directory:  D:\NetApp\DataFabricManager\reports\

Plugins Directory:          D:\NetApp\DataFabricManager\plugins

Database Hosting System:    usgrprena001

Database Location:          /vol/usgr_iscsi_prevs721_dfm/data/lun_d

SnapDrive Installed:        Yes

SnapDrive Version:          6.3.1.5028

SnapDrive Status:           Passed

Volume Snapshot Status:     Disabled

Backup Retention Count:     10

Allowed Backup Types:       Snapshot (sndb), Archive (ndb)

Database Mirror Status:     Disabled

Mirror location:

Re: OnCommand Core 5.0 - perfdata directory setting problem!

Hi all,

Please open up support cases for this. I believe this is BURT498695 and has no single support case attached to it.

If they have no support cases, it's obviously no problem and does not need fixing. I believe otherwise.

Thanks


Christoph

Re: OnCommand Core 5.0 - perfdata directory setting problem!

Case (2002771192) is created, lets see how many months it will take to get a reaction from Support/Engineering ...

This is especially annoying, seeing that it was solved in some branch of the code. And then they used another branch to plant the "OnCommand GUI" on top of DFM and re-introduce the issue.

BTW, this BURT is not public accessible and does not match the problem, according to netapp support...

Re: OnCommand Core 5.0 - perfdata directory setting problem!

Hi

    The bug mentioned is similar but not the same a new bug is raised for this issue and your case is attached to it. Bug id 560602.

Regards

adai

Re: OnCommand Core 5.0 - perfdata directory setting problem!

hmmm...