Subscribe
Accepted Solution

OnCommand Plugin 4.1.1 Installation Error

[ Edited ]

I am trying to install the OnCommand Plug-in 4.1.1 but half way through the installation I am recieving attached error. I am trying to install the software on our SCOM Management Server running SCOM 2012 R2 and on Windows Server 2012 R2.  This seems to be occuring when trying to create the OCPM database.

 

After pressing 'Ok' to proceed I then see the error attached named NetApp411 Error2

 

When checking the log it gives me the following information

 

===========

 

16/06/2016 09:25:34
Could not load file or assembly 'Microsoft.SqlServer.Smo, Version=11.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91' or one of its dependencies. The system cannot find the file specified.
at NetApp.SCI.Common.SCIDatabase.ManageDB.CreateDatabase(DatabaseConfig ocpmDatabaseConfig)
at NetApp.SCI.Tools.ManageDatabase.DatabaseSetup.Main(String[] args)

 

===========

 

 

Has anyone had this error before? Can anyone provide me with a resolution? If you require any more details please ask.

 

Re: OnCommand Plugin 4.1.1 Installation Error

Ok, i've managed to sort this. It appears that you need to have the SQL 2012 SharedManagementObjects.msi and SQLSysClrTypes.msi installed on the SCOM Management Server. (I didn't see this in the documentation anywhere)

Re: OnCommand Plugin 4.1.1 Installation Error

Hello,

I have got the same error, but we are using SQL2008R2SP2. Product compatibility matrix says  SQL2008R2 should be supported but not.