Subscribe

Oncommand Unified Manager 7 on RHEL 6.7 - netapp-ocum-7.0-x86_64.rpm post install script broken

In the current OnCommandUnifiedManager-rhel6-7.0.zip package, the netapp-ocum-7.0-x86_64 package is broken.  The post install script has a function configure_rp() to register UM with the reverse proxy.  Unfortunately this script /opt/netapp/ocum/bin/um register searches for the JAVA keystores in /data/ocie but the keystores are installed in /opt/netapp/data/ocie which is set in the script via these variables:

 

datadir="/opt/netapp/data"

UM_KEYSTORE="${datadir}/ocie/server.keystore"

 

sh -x /opt/netapp/ocum/bin/um register
+ UM_HOME=/opt/netapp/ocum
+ LIB_ROOT=/opt/netapp/ocum/lib/cli
+ export LIB_ROOT
+ cd /opt/netapp/ocum
+ JVM_ARGS=' -client'
+ JVM_ARGS=' -client -Xms64M'
+ export JVM_ARGS
+ MAIN_CLASS=com.netapp.dfm.cli.handlers.rest.CliRestMain
+ exec ./bin/launch-java com.netapp.dfm.cli.handlers.rest.CliRestMain um register
Failed to update RP registry with UM metadata. Check logs for more details

 

------------- /var/log/ocum/cli.log --------------------------------------------------
2017-01-26 13:21:55,454 ERROR [main] [c.n.d.c.r.r.HttpsRestTemplate] Error during SSL initialization of restTemplate for issuing calls to RP : /data/ocie/server.keystore (No such file or directory)
2017-01-26 13:21:55,454 ERROR [main] [c.n.d.c.r.r.RpRegistryUpdateService] Error fetching registry entry for UM : java.io.FileNotFoundException: /data/ocie/server.keystore (No such file or directory)

 

The workaround:

 

yum install ocie-serverbase-1.4.0-2016.09.J2286.x86_64.rpm \
netapp-application-server-1.4.0-2016.09.J2286.x86_64.rpm \
netapp-platform-base-1.4.0-2016.09.J2286.el6.x86_64.rpm \
node.x86_64.rpm rp.x86_64.rpm \
ocie-server-1.4.0-2016.08.J2307.x86_64.rpm \
ocie-au-1.4.0-2016.08.J2307.x86_64.rpm \
rp.x86_64.rpm

 

ln -s /opt/netapp/data/ocie/ /data/ocie

chown jboss:jboss /data/ocie
chmod 755 /data

 

yum install netapp-ocum-7.0-x86_64.rpm

Re: Oncommand Unified Manager 7 on RHEL 6.7 - netapp-ocum-7.0-x86_64.rpm post install script broken

Here is the function for reference:

 

------------------------------------------------------------------------------------------------------------
function configure_rp() {
log "Registering UM with reverse proxy"
/opt/netapp/ocum/bin/um register >> $LOG 2>&1

log "Checking whether UM was registered successfully with RP"

#OR with true to make sure that subsequent if statement is hit sucessfully
#and installer doesn't terminate on the grep call itself
um_registry=`grep -i "\"um\"" ${OCIE_HOME}/data/app_registry.json` || true
if [[ ${um_registry} =~ "um" ]]; then
log "Found um entry in ${OCIE_HOME}/data/app_registry.json file. Registration successful."
log "${um_registry}"


echo_log "Installer failed to register UM with Reverse Proxy. Refer log for more details"
else
log "Failed to find um entry in ${OCIE_HOME}/data/app_registry.json file. Installer will exit now"
echo_log "Installer failed to register UM with Reverse Proxy. Refer log for more details"
exit -1
fi
}
------------------------------------------------------------------------------------------------------------

Re: Oncommand Unified Manager 7 on RHEL 6.7 - netapp-ocum-7.0-x86_64.rpm post install script broken

Please open a case and include these details.  Thanks.