Subscribe

Performance Advisor: CLI data collection command not working as defined

Working with a customer today on setting up Performance Advisor data collection and encountered a command that does not work as defined.

Customer wanted to script enabling counter collection for NFS across all his controllers. He specifically wanted to turn on all NFS counters to have them available for diagnostics. Since he has a lot of controllers, scripting it was the preferred way to go.

According the the CLI help, the command is pretty straightforward:

dfm perf data enable [-p] <host-name-or-id> <perf-object-type> { all | <counter-name> ...}

So the syntax should be

dfm perf data enable <controller> nfsv3 all

Executing it on the customer's system produced the message "All the supplied counters are already enabled". Executing the command, specifying a specific counter instead of 'all' was successful. (screenshot)

And to confirm that not all counters were enabled, I have this screenshot from the UI.

The question: Is the expected behavior that the 'all' option on the dfm perf data enable command will enable ALL counters of the specified type (nfsv3 in this case). If so, then we appear to have a bug.

Tested on OC 5.0 (Windows 64-bit) and OpsMgr 4.0.2 (Windows).

Re: Performance Advisor: CLI data collection command not working as defined

Hello,

This is a bug in "dfm perf data enable all" CLI. I am able to reproduce this issue. From GUI we can select any counter to enable or disable it and that reflect properly in that counter group.

But from CLI, "all" option does not work. Please file a bug for this issue.

Thanks,

Bipul

Re: Performance Advisor: CLI data collection command not working as defined

Hi Phil,

           Bug 592321 is filed for the same, pls add your customer case to the same.

Regards

adai

Re: Performance Advisor: CLI data collection command not working as defined

Adai,

Customer and I were working to enable collection of nfs counters. Because we figured out a workaround, he did not open a case.

Phil

Re: Performance Advisor: CLI data collection command not working as defined

Help please.

All our boxes works perfectly respond but except one device

dfm perf data enable -p X volumes all

Error: Could not get details of counter group volumes

Reason: Supplied storage storage system[1283] is not compatible

the problem is X doesnot collect performance data but collects all other. Same version in same chasis there is Y. And Y's performance data is collected without any problem.

Please help me. I put to much time to this.

Appriciated.