Subscribe

Problem with OCPM 4.1 for Microsoft SCOM

[ Edited ]

Hi,

 

we are using above mentioned solution for monitoring our FAS Systems (7-Mode and cDOT).

After installing the OCPM 4.1 within SCOM 2012R2 our Exchange SCOM Management Pack did not work anymore.

 

A call at Microsoft yieled this:

"

ROOT CAUSE:

==============

The issue is caused because in OM 2012 the sproc p_SelectForTypeCache can return NULL values for ImageCategory when retrieving the Image Ressources if some Management Packs did not have this defined. In this case the Management Pack which was causing this was the  MP, but essentially the sproc should be fixed to not return NULL values.

 

Following shouldn't return NULL for the column ImageCategory :

 

"SELECT [ImageReference].[ImageId], [ImageReference].[ReferenceId], [ImageReference].[ManagementPackId], [ImageReference].TimeAdded, [ImageReference].LastModified, SUBSTRING([EnumType].EnumTypeName, 39, 100) AS ImageCategory, [MPElementView].[MPElementName],

  [ManagementPack].[ContentReadable]

  FROM dbo.ImageReference

  JOIN dbo.[Resource] on ([Resource].ResourceId = ImageReference.ImageId)

  LEFT JOIN dbo.[Category] ON [Category].CategoryTarget = [Resource].ResourceId

  LEFT JOIN dbo.[EnumType] ON [EnumType].EnumTypeId = [Category].CategoryValue

  JOIN dbo.MPElementView ON (ImageReference.ReferenceId = MPElementView.MPElementId)

INNER JOIN dbo.[ManagementPack] ON dbo.ManagementPack.ManagementPackId = [ImageReference].ManagementPackId AND dbo.ManagementPack.ContentReadable = 1

WHERE dbo.[ImageReference].[ReferenceId] IN (select dbo.ManagedType.ManagedTypeId from dbo.ManagedType)

    and dbo.[Resource].ResourceType = 4"

 

Any ideasd how to fix this?

Will there be an update of OCPM fixing this?

 

Thanks in advance!

regards

 

Re: Problem with OCPM 4.1 for Microsoft SCOM

I am having a similar issue. After installing and configuring OnCommand Clustered Data ONTAP managemnt Pack and rebooted my RMS server, it broke Exchange 2010 MP. Specifically the Microsoft Exchange Monitoring Correlation Service on the RMS crashed. I am unable to Start it. which makes the Exchange 2010 useless. I have contacted NetApp support and waiting for a reply. 

Re: Problem with OCPM 4.1 for Microsoft SCOM

My fix for this issue.

The query from STEFANDELFS post returns two results, associated with FCPAdapter image, with null ImageCategory field.
Run the query:
SELECT * FROM [dbo].[Category] where CategoryName like 'Cat.dataontap%' order by CategoryName
You will see that field CategoryTarget for 'Cat.DataONTAP.Cluster.NodeVserver.FCPAdapter.Image.Large' is the same as for category 'Cat.DataONTAP.Cluster.DataVserver.Volume.SMBShare.Image.Large'. The same is for 'small' version of this image. Looks like copy/paste when creating objects. You shoud replace CategoryTarget for FCPAdapter with correct values. You can take it from the ResourceId field of the query:
SELECT * FROM [dbo].[Resource] where FileName like '%fcpadapter%'
This works for me.

Re: Problem with OCPM 4.1 for Microsoft SCOM

Nala, thank you - your fix appears to have done the trick for us!


I just want to add the actual queries to run, just running these two queries in our environment fixed the issue.  As always, make sure you have a backup before you do any manual updates to your SQL database!

 

Also, the correlation service wouldnt' start for us until we restarted our SCOM server.

 

UPDATE dbo.Category
SET CategoryTarget='1469A3E7-BC77-3551-3AA7-290DBEA7C72D'
where CategoryName='Cat.DataONTAP.Cluster.DataVserver.Volume.SMBShare.Image.Large'
UPDATE dbo.Category
SET CategoryTarget='6AF8CD6B-C876-E0D2-00C0-5EEB0F134729'
where CategoryName='Cat.DataONTAP.Cluster.NodeVserver.FCPAdapter.Image.Small'