Community

Subscribe
Highlighted
Accepted Solution

Problem with UserName in "Set CIFS Share ACL" command

I'm trying to add an AD group to a CIFS share as part of the workflow using the Set CIFS Share ACL certified command and I get the following error:

[Error: illegal escape sequence: A]

[Near : {... AUTHORITY\Authenticated Users ....}]

                                         ^

The group I'm trying to add is called "NT AUTHORITY\Authenticated Users" (double quotation marks are included in the input) so I'm assuming that WFA has an issue with the \ in the input. Are there any characters I need to surround it in so WFA just reads it as part of the text?

Re: Problem with UserName in "Set CIFS Share ACL" command

Hi Tim,

Can you provide group input value with double backslashes as : "NT AUTHORITY\\Authenticated Users".

Tried the same and it seems to be working as expected in the preview stage.

Regards,

Tanzim

Re: Problem with UserName in "Set CIFS Share ACL" command

Hi Tanzim,

Thanks for the help, that's fixed the issue. I'm assuming that any input in a workflow needs to have the extra \ to make sure that WFA inteprets it correctly?

Re: Problem with UserName in "Set CIFS Share ACL" command

Hi Tim,

I'm not quite sure about what you mean by "any input in a workflow".

Again, with reference to the issue discussed in this thread, a backslash needs to be preceded by another backslash to prevent it from being interpreted as an escape sequence.

Regards,

Tanzim

Re: Problem with UserName in "Set CIFS Share ACL" command

Hi tanzim,

Yes that's what I meant. Thanks for your help