Subscribe

Problem with vRealize Orchestrator Package for OnCommand Workflow Automation 3.1 and vRA/vRO 7.3

I've a problem with the vro Package for WFA. I have WFA 4.1 and vRA/vRO 7.3 installed.

I've installed the vro package and configured WFA.

I've configured a workflow without parameters and it work correctly.

 

Now I'm trying to create a workflow with parameters but I get an error related to parameters not found.

 

I've created a small workflow with just one mandatory parameter and configured it following the guide in the vro package and also checked http://www.netapp.com/us/media/tr-4306.pdf

All seems correctly configured but the parameters are not recognized.

I've also changed the workflow to only have a script that populate and array and pass it to the workflow launch.

The workflow only have a parameter called "domirror"

 

Workflow (only script and run of the workflow)

imageb.png

 

This is my script in the bind inputs

 

 

var workflowInputValues = new Array();

var x = new VcOptionValue();
x.key = "domirror";
x.value = domirror;
workflowInputValues.push(x);

 

This is the script binding

imagea.png

 

 

Workflow binding:

imagec.png

 

 

Debug information

 

[2017-06-22 01:31:32.858] [D] #### Processing WFA workflow input validation ####
[2017-06-22 01:31:32.859] [D] A total of 1 inputs were provided to this workflow by vCO
[2017-06-22 01:31:32.860] [D] Input names and values:
[2017-06-22 01:31:32.863] [D] undefined = undefined
[2017-06-22 01:31:32.864] [D] WFA workflow has 1 inputs defined
[2017-06-22 01:31:32.865] [D] Parsing input #0
[2017-06-22 01:31:32.866] [D] Input has name domirror and mandatory is true
[2017-06-22 01:31:32.867] [D] 1 mandatory inputs now exist.
[2017-06-22 01:31:32.868] [D] %%%%%%%%%%%%%%%%%%%%%%%
[2017-06-22 01:31:32.869] [D] Total number of WFA Inputs: 1
[2017-06-22 01:31:32.870] [D] Total number of mapped vCO Inputs: 0
[2017-06-22 01:31:32.871] [D] WFA has 1 mandatory inputs
[2017-06-22 01:31:32.872] [D] vCO/user has provided 0 mandatory inputs
[2017-06-22 01:31:32.873] [D] %%%%%%%%%%%%%%%%%%%%%%%
[2017-06-22 01:31:32.890] [D] Using stored REST host with id f31679b2-17a9-4c07-bacc-59189a3a5c71
[2017-06-22 01:31:32.892] [D] Stored and passed are the same. No destruction.

Re: Problem with vRealize Orchestrator Package for OnCommand Workflow Automation 3.1 and vRA/vRO 7.3

Hi,

 

Here is a useful link to config vRA\vRO to invoke WFA workflows (and some useful links within the article)

 

http://practical-admin.com/blog/executing-wfa-workflows-from-vcenter-orchestrator-using-rest/#more-1554

 

Can you successfully run your WFA workflow within the WFA web portal?

 

/Matt

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: Problem with vRealize Orchestrator Package for OnCommand Workflow Automation 3.1 and vRA/vRO 7.3

[ Edited ]

The workflow works correctly from WFA. The only problem seems to be related to the parameters.

The workflow I'm using is a single workflow with just one step that do a sync on a snapmirror. 

It normally have no parameters (all defined in the workflow) and I've just put a "boolean" parameter called "domirror" to enable disable the action but from VRO the workflow is not called as VRO is not finding the only input/parameter I'm passing to it.

 

 

Checking on the site you linked I've tried to use the action without the script and it get the same results. It seems that the workflow that validate the parameters sees the parameters array but don't get correct value from it... 

imaged.png

[2017-06-22 08:43:08.763] [D] Gathering workflow inputs...
[2017-06-22 08:43:08.765] [D] Parent workflow: Do update SAPSoftware2
[2017-06-22 08:43:08.766] [D] Found 1 inputs defined.
[2017-06-22 08:43:08.767] [D] Input names: domirror
[2017-06-22 08:43:08.768] [D] Parsing input domirror
[2017-06-22 08:43:08.769] [D] Input is a string object type.
[2017-06-22 08:43:08.770] [D] Value is false
[2017-06-22 08:43:08.814] [D] Using stored REST host with id f31679b2-17a9-4c07-bacc-59189a3a5c71
[2017-06-22 08:43:08.845] [D] #### Starting execution of Find WFA Workflow ID ####
[2017-06-22 08:43:08.849] [D] Workflow url: /workflows?name=Q8%20TestWF
[2017-06-22 08:43:08.854] [D] %% Executing REST request %%
[2017-06-22 08:43:08.855] [D] URL: /workflows?name=Q8%20TestWF
[2017-06-22 08:43:08.990] [D] REST status code: 200
[2017-06-22 08:43:08.993] [D] Found 1 workflows with name Q8 TestWF
[2017-06-22 08:43:08.994] [D] Preview URL: /workflows/bd65d978-aa0c-477b-a41d-37d9e70e6652/preview
[2017-06-22 08:43:08.996] [D] Job URL: /workflows/bd65d978-aa0c-477b-a41d-37d9e70e6652/jobs
[2017-06-22 08:43:08.997] [D] Out URL: /workflows/bd65d978-aa0c-477b-a41d-37d9e70e6652/out
[2017-06-22 08:43:09.017] [D] Using stored REST host with id f31679b2-17a9-4c07-bacc-59189a3a5c71
[2017-06-22 08:43:09.019] [D] Stored and passed are the same. No destruction.
[2017-06-22 08:43:09.065] [D] Using stored REST host with id f31679b2-17a9-4c07-bacc-59189a3a5c71
[2017-06-22 08:43:09.113] [D] Workflow url: /workflows?name=Q8%20TestWF
[2017-06-22 08:43:09.132] [D] %% Executing REST request %%
[2017-06-22 08:43:09.133] [D] URL: /workflows?name=Q8%20TestWF
[2017-06-22 08:43:09.229] [D] REST status code: 200
[2017-06-22 08:43:09.240] [D] #### Processing WFA workflow input validation ####
[2017-06-22 08:43:09.241] [D] A total of 1 inputs were provided to this workflow by vCO
[2017-06-22 08:43:09.242] [D] Input names and values:
[2017-06-22 08:43:09.244] [D]  undefined = undefined
[2017-06-22 08:43:09.245] [D] WFA workflow has 1 inputs defined
[2017-06-22 08:43:09.246] [D] Parsing input #0
[2017-06-22 08:43:09.247] [D] Input has name domirror and mandatory is true
[2017-06-22 08:43:09.248] [D] 1 mandatory inputs now exist.
[2017-06-22 08:43:09.249] [D] %%%%%%%%%%%%%%%%%%%%%%%
[2017-06-22 08:43:09.250] [D] Total number of WFA Inputs: 1
[2017-06-22 08:43:09.251] [D] Total number of mapped vCO Inputs: 0
[2017-06-22 08:43:09.252] [D] WFA has 1 mandatory inputs
[2017-06-22 08:43:09.253] [D] vCO/user has provided 0 mandatory inputs
[2017-06-22 08:43:09.254] [D] %%%%%%%%%%%%%%%%%%%%%%%
[2017-06-22 08:43:09.265] [D] Using stored REST host with id f31679b2-17a9-4c07-bacc-59189a3a5c71
[2017-06-22 08:43:09.267] [D] Stored and passed are the same. No destruction.
[2017-06-22 08:43:09.373] [E] Workflow execution stack:
***
item: 'Do update SAPSoftware2/item4', state: 'failed', business state: 'null', exception: 'Found 0 inputs. The WFA workflow has 1 mandatory inputs, only 0 were found. (Workflow:Verify WFA Workflow Inputs / Parse Inputs (item1)#97)'
workflow: 'Do update SAPSoftware2' (9f6c0481-0c51-47d5-97ed-575e9d01aa26)
| 'attribute': name=errorCode type=string value=Found 0 inputs. The WFA workflow has 1 mandatory inputs, only 0 were found. (Workflow:Verify WFA Workflow Inputs / Parse Inputs (item1)#97)
| 'attribute': name=workflowName type=string value=Q8 TestWF
| 'attribute': name=wfaWorkflowJobID type=string value=null
| 'attribute': name=returnWFAParameters type=Properties value=null
| 'attribute': name=userInputs type=Array value=#{#Any#pojo#rO0ABXNyACpjaC5kdW5lcy52c28uc2RrLlBPSk9Db252ZXJ0b3IkVGFnZ2VkVmFsdWUAAAAAAAAAAQMAAkwABm9iamVjdHQAEkxqYXZhL2xhbmcvT2JqZWN0O0wACnBsdWdpbk5hbWV0ABJMamF2YS9sYW5nL1N0cmluZzt4cHcEAAJWQ3NyADZjb20udm13YXJlLm8xMW4ucGx1Z2luLnZzcGhlcmVfZ2VuLk9wdGlvblZhbHVlX1dyYXBwZXIAAAAAAAAAAQMAAHhyAC9jb20udm13YXJlLm8xMW4uc2RrLm1vZGVsZHJpdmVuLkFic3RyYWN0V3JhcHBlcgAAAAAAAAABAgACTAAHX3RhcmdldHEAfgABTAAGcm9vdElkdAAlTGNvbS92bXdhcmUvbzExbi9zZGsvbW9kZWxkcml2ZW4vU2lkO3hwc3IALWNvbS52bXdhcmUudmltLmJpbmRpbmcudmltLm9wdGlvbi5PcHRpb25WYWx1ZQAAAAAAAAABAgACTAADa2V5cQB+AAJMAAV2YWx1ZXEAfgABeHIAMWNvbS52bXdhcmUudmltLmJpbmRpbmcuaW1wbC52bW9kbC5EeW5hbWljRGF0YUltcGwAAAAAAAAAAQIAAlsAD2R5bmFtaWNQcm9wZXJ0eXQAL1tMY29tL3Ztd2FyZS92aW0vYmluZGluZy92bW9kbC9EeW5hbWljUHJvcGVydHk7TAALZHluYW1pY1R5cGVxAH4AAnhyADBjb20udm13YXJlLnZpbS5iaW5kaW5nLmltcGwudm1vZGwuRGF0YU9iamVjdEltcGwAAAAAAAAAAQIAAlsAEF9keW5hbWljUHJvcGVydHlxAH4ACkwADF9keW5hbWljVHlwZXEAfgACeHBwcHBwdAAIZG9taXJyb3J0AAVmYWxzZXBwcHVyAAJbQqzzF/gGCFTgAgAAeHAAAAGTrO0ABXNyAC1jb20udm13YXJlLnZpbS5iaW5kaW5nLnZpbS5vcHRpb24uT3B0aW9uVmFsdWUAAAAAAAAAAQIAAkwAA2tleXQAEkxqYXZhL2xhbmcvU3RyaW5nO0wABXZhbHVldAASTGphdmEvbGFuZy9PYmplY3Q7eHIAMWNvbS52bXdhcmUudmltLmJpbmRpbmcuaW1wbC52bW9kbC5EeW5hbWljRGF0YUltcGwAAAAAAAAAAQIAAlsAD2R5bmFtaWNQcm9wZXJ0eXQAL1tMY29tL3Ztd2FyZS92aW0vYmluZGluZy92bW9kbC9EeW5hbWljUHJvcGVydHk7TAALZHluYW1pY1R5cGVxAH4AAXhyADBjb20udm13YXJlLnZpbS5iaW5kaW5nLmltcGwudm1vZGwuRGF0YU9iamVjdEltcGwAAAAAAAAAAQIAAlsAEF9keW5hbWljUHJvcGVydHlxAH4ABEwADF9keW5hbWljVHlwZXEAfgABeHBwcHBwdAAIZG9taXJyb3J0AAVmYWxzZXh4#}#

| 'input': name=domirror type=string value=false
| 'no outputs'
*** End of execution stack.

Re: Problem with vRealize Orchestrator Package for OnCommand Workflow Automation 3.1 and vRA/vRO 7.3

I've just done a test with a vRO 6.0.3.

I've installed the netapp package and create the same workflow. It has run without any problems so it seems something related to vRO 7.3 

Anyone used this package with vRO 7.x ? 

 

Re: Problem with vRealize Orchestrator Package for OnCommand Workflow Automation 3.1 and vRA/vRO 7.3

In the log, the output from the workflow execution it has these entries:

 

[2017-06-22 01:31:32.860] [D] Input names and values:
[2017-06-22 01:31:32.863] [D] undefined = undefined

It's not recognizing the VcOptionValue object(s) in the array you're passing in.  This may be a "feature" of 7.3, where it's changed something about that object.  

 

If you look at the API Explorer in vRO it may give you some idea of what the object's methods are now.  They may have changed, which is causing the issue.  Here is the original:

 

2017-06-22 10_04_41-10.63.171.164 - Remote Desktop Connection Manager v2.7.png

 

Andrew

If this post resolved your issue, please help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: Problem with vRealize Orchestrator Package for OnCommand Workflow Automation 3.1 and vRA/vRO 7.3

Yes, there's something strange about the plugin for vCOptionValue.

I've posted on the vmware site and something not working with vRO 7.3 related to that specific plugin (it's a new version in vro 7.3).

This is the thread in the vmware community forum regarding the problem https://communities.vmware.com/message/2683622

 

I'm trying to use the method explained in the message and i get ahead from the parameters check (now it works) but the next step in the workflow fails because it still use a VcOptionValue to create the userInputValues for the next workflow.

 

I think the only solution are to change the workflows to not use the VcOptionValue or wait for a fix (on vmware forum it seems that this is some kind of bug).

 

Re: Problem with vRealize Orchestrator Package for OnCommand Workflow Automation 3.1 and vRA/vRO 7.3

It's possible to replace an array of VcOptionValue objects with a Properties object of key:value pairs, but it would require some updates across the NetApp workflows.  

 

At a minimum, these things would need updating:

 

  • The generateNetAppWFA_Inputs action
  • The generateNetAppWFA_UserInputXML action
  • The "Verify WFA Workflow Inputs" workflow
  • And any workflows which have a scriptable task binding inputs, such as your example

 

Most of the work would need to be done in the generatenetAppWFA_UserInputXML action to replace it's loop over the array of VcOptionValues with a loop over the keys of a Properties object.

 

Andrew

If this post resolved your issue, please help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: Problem with vRealize Orchestrator Package for OnCommand Workflow Automation 3.1 and vRA/vRO 7.3

I've changed all the workflows in the package with the workaround suggested on vmware site and it seems to work correctly now. 

 

Instead of using:

  1. var x = new VcOptionValue();    
  2. x.key = "p1";    
  3. x.value = p1;    

I've changed all vcoptionvalue this way:

  1. var x = {"key":"p1""value":p1}  

 

Re: Problem with vRealize Orchestrator Package for OnCommand Workflow Automation 3.1 and vRA/vRO 7.3

I faced the same issue. Resolved by changing " = new VcOptionValue() " to " = new Object() " in all the scripts inside the vRealize Orchestrator Package for OnCommand Workflow Automation 3.1.0.