Subscribe
Accepted Solution

Protection Manager not honoring ndmpd.prefrerred interface?

Hi,

I have recently experienced this issue with SnapVault using the wrong interface at 2 different customer sites with different DFM versions, slightly different DOT versions.

Customer 1, OM 4.0.2D5, DOT on primary 8.0.2, secondary 8.1RC1.

I first noticed the problem after secondary system was upgraded from 8.0.1 to 8.1RC1.

Customer 2, OC Core 5.0, DOT 8.0.2P3 on both primary and secondary.

In both cases, checking the Protection Manager Job details, I can see that the correct IP was retrieved.

Despite this the SnapVault session is setup using the "default" IP, the primary in DFM. In customer 2's case, this is e0M

Tried to search for applicable BURTs but no apparent matches.

Any ideas what could be wrong?

Thanks in advance,

Erik Stjerna

Message was edited by: erik stjerna Forgot to mention we're working around the issue with static entries in /etc/hosts of the respective secondaries, not a very durable or elegant solution...

Re: Protection Manager not honoring ndmpd.prefrerred interface?

Replying to self. Will I get banned for this

Anyway BURT 540170 seems to be the one. Fixed in OC Core 5.0D1.

Message was edited by: erik stjerna - corrected BURT number

Re: Protection Manager not honoring ndmpd.prefrerred interface?

Hi Erik,

Do you have anymore information on this issue as we are experiencing the same problem! Is there a work around to get our SNAPVault destination using anything other that e0M.

Many Thanks

Austin

Re: Protection Manager not honoring ndmpd.prefrerred interface?

Hi Austin.

     Refer to this KB article on "How to run SnapVault over a non-primary interface in the Protection Manager"

     https://kb.netapp.com/support/index?page=content&id=1010493

And enable set the following option

dfm option set ndmpDataUseAllInterfaces=1

Regards

adai

Re: Protection Manager not honoring ndmpd.prefrerred interface?

Seems I entered the wrong BURT ID above, wasn't very helpful..

This is the one: http://now.netapp.com/NOW/cgi-bin/bol?Type=Detail&Display=540170

Workaround if you cannot go to 5.0D1 is to set:

dfm option set ndmpDataUseAllInterfaces=1

Regards,

Erik