Community

Subscribe
Highlighted

Provisioning Manager and AutoSize on Thin Volumes

Why is there no way to set volume autosize when I do a full thin provision on a LUN (Do not guarantee space for LUN or snapshot copies) from Provisioning Manager? We recently had an issue where some LUNs offlined because PM didn't set vol autosize on the containing volume. I scripted the change via PowerShell, but now all my datasets have a big red x because they are non-conformant. The system wants to turn off autosize to make them conform!

It looks like my only option is to guarantee space for the LUN (not thin provision it, and not an option as it were), or be stuck with big red alarming error messages every time I am in the PM console. Is there a hotfix available for this, or are we just out of luck?

E-

Re: Provisioning Manager and AutoSize on Thin Volumes

Hello Erick,

     This has been an old and well known limitation with Provisioning Manager(PM). When PM was designed it was with the aim of keeping the things as simple as possible and going with the most common settings that a user will try out. But this had a drawback of the product being less flexible. With time and with the increasing usage of PM we are seeing many customers asking for more flexibility in provisioning options. This issue is taken up very seriously by our team. Also the issue for a forced conformance upon user's conscious decision is also being looked at. I'm sure there is a feature burt regarding this or if not I'll file one.

     Till DFM 4.0.1 this limitation is existing, but with the future release I think this might be available. But I can't promise when or to what extent.

Thank you for your post and patience.

Warm regards,

Abhishek

Re: Provisioning Manager and AutoSize on Thin Volumes

Hello Erick,

Yes, there is no option today for setting autosize on thinly provisioned

volumes/LUNs from Provisioning Manager. So for this configuration your

dataset will be Non-Conformant if you set autosize ON.

This option is available on thickly provisioning volumes where ( LUN also

space reserved) fractional reserve is set to 0. And autodelete is also ON.

We don¹t have a hotfix available now; but it¹s there in roadmap. You can

file an RFE to track this issue or please get in touch with our Product

Management to address this.

I have few questions on your setup:

1. Which ONTAP version are you running?

2. Do you have snapshots on this volumes?

Thanks

Tanmoy

Re: Provisioning Manager and AutoSize on Thin Volumes

Yes we do have snapshots on the volumes in question. They are large Oracle databases. We are running ONTAP 8.0.1 7-Mode.

Re: Provisioning Manager and AutoSize on Thin Volumes

Is not autodelete ON for these volumes? The thin Provisioning configuration which you are using; will set autodelete ON.

Trying to understand under what circumstances the LUNs went offline. If volume ran out of space; then autodelete should have triggered which might not be of any interest or choice for customer; they won't like to see loosing snapshots.

But did not it happen?

Re: Provisioning Manager and AutoSize on Thin Volumes

Our DBA is doing a migration, and we added 25, 80gb luns. The luns were created using PowerShell and not via PM. We have since used another PowerShell script to make certain all volumes are set to auto grow. The problem here could also happen if any other management tool is used, System Manager, Filer View, cli, etc.

Re: Provisioning Manager and AutoSize on Thin Volumes

I have posted a quick PowerShell script that will alleviate the issue:

http://www.theselights.com/2011/03/using-powershell-to-netapp-provisioning.html

Thanks,

Erick

Re: Provisioning Manager and AutoSize on Thin Volumes

Has this been released yet? I'm running OnCommand Unified Manager 5.0.1, and I can't find a space setting in the SAN container properties of a provisioning policy that has thin-provisioned LUNs and autosize enabled.