Subscribe
Accepted Solution

Resetting WFA's database

I'm sure this is a strange corner-case question. I'm not sure my question is clear so I'll explain my environment and history. It is a lab env for testing/learning only. Over recent months I have had this WFA system tied to two different OCUM data sources (call them OCUM#1 and OCUM#2). FWIW, this is a Clustered ONTAP test env using OCUM 5.1. The current OCUM#2 I have set up as a Data Source is the one I am using and want to keep. However, I can see that WFA still has knowledge of some of the things it learned while it was connected to OCUM#1 (vserver names, etc). Some of those things are for the same cDOT clusters (sims). WFA is referencing and presenting as options old vserver names that were around when OCUM#1 was the data source but have since been renamed or deleted. There doesn't seem to be anyway to get rid of them. I'd like to clear out that old information but I think it's not going to go away (... unless maybe I re-added the old OCUM#1 data source again and it updated and un-learned old vserver info ... but that is impossible as I have whacked OCUM#1 out of existence)

Is there a way to just factory-default the WFA database? I presume a re-install of the same or newer WFA wouldn't wipe it's data source database.

This is WFA version 2.0.0.391.2

Re: Resetting WFA's database

... and I should add that I have removed the old OCUM#1 Data Source reference so the system just points to OCUM#2 now.

Re: Resetting WFA's database

The simplest option would be to 'Reset the Scheme'.  Edit the existing cm_storage Data Source.  Select the Scheme type and then click 'Reset Scheme'.  This action will drop all of the tables associated with the cm_storage scheme and then load after a successful acquisition.

Jeremy Goodrum, NetApp

The Pirate

Twitter: @virtpirate

Blog: www.virtpirate.com

Re: Resetting WFA's database

Perfect. That did the trick. Thanks Jeremy≥

Re: Resetting WFA's database

Sorry to bump an old thread, but this has become relevant again.  I'd like to do this, but I'm running 2.1.  Has the functionality to reset the schema been moved or removed?

Re: Resetting WFA's database

I haven't got a 2.1 system to quickly look at but my WFA 2.2 system still has the same Reset Scheme button. So I'd assume v2.1 does as well. It is at the bottom of an Execution-tab -> Data Source -> Edit window. You have to select/highlight the Scheme line under Scheduler configuration or the button will be grayed out.

Re: Resetting WFA's database

Thanks!  I now understand how to do this.

To clarify for anyone else reading this, "Reset Schema" clears ALL of your data sources, not just the source you selected the "Edit" button from.

Afterwards, re-acquiring from your remaining data sources solves the issue.

Thank you, korns!