Subscribe

SLO Pack - find PSL backup_only works but disaster_only fails to create then find destination volume

[ Edited ]

Been working with SLO Pack for a couple of days with mostly good success. I notice the documentation mentoned ONTAP 8.2.1 as a prerequsite. Two of my lab clusters (B & C) are 8.2, not 8.2.1 ... could that be causing what I'm seeing.

 

I've done the following minimal setup steps to learn and test the product:

 

  - I mapped aggregates with some of the built-in SSLs as follows:

        - Value - maps to an aggr on cluster-A which is running 8.3 (vsim)

        - Extreme - maps to an aggr on cluster-B which is running 8.2 (vsim)

        - Capacity - maps to a pair of aggrs on cluster-C which is running 8.2 (vsim)

  - I updated three of the built-in PSLs to: 

        - backup_only - Edge Destination points to the above modified SSL: Capacity SSL 

        - disaster_only - Edge Destination points to the above modified SSL: Capacity SSL 

        - snapshots_only - Edge Destination points to the above modified SSL: Capacity SSL  (though for snapshots_only this probably wasn't nessecary)

  - I've added my own SLs that reference these SSLs and PSLs as follows to test 

        - Silver - uses SSL: Value, PSL: snapshots_only 

        - Gold - uses SSL: Performance, PSL: backup_only 

       - Platinum - uses: SSL: Extreme, PSL: disaster_only

 

Testing so far:

  - provisioning volumes with SL: Silver - creating columes on an 8.3 system with snapshots_only - all tests look good

  - provisioning volumes with SL: Gold - creating src-vols on an 8.2 system and dst-vols on 8.2 and XDP SnapVault relations - all tests look good

  - provisioning volumes with SL: Platinum - creating src-vols/dst-vols on 8.2 - workflow won't preview failing on dest-volume step (see below)

 

 In looking at the steps in the Service based volume provisioning worklow I notice this preview error is at a step that is attempting to reference back to the previously created destination volume ... but that step (probably 'Create Destination vault volume') is not previewing in the workflow and hence destination_volume reference object does not exist. I notice the erm 'vault' used in the previous command and since this SL is disaster_only and implies SnapMirror/DP, wonder if that is relavent or not. -OR- could this have to do with obscure difference between 8.2 and 8.2.1 that let PSL: backup_only owrk but not disaster_only.

 

hard to see the entire 'flow' preview so including the execution plan format:

Plat_fail_preview.png