Subscribe

Setting QosPolicyGroup in the "Create volume" workflow has a bug

Hi there,

in the cm_storage Create volume workflow, the QosPolicyGroup setting is not working.  I took a look, and I see that there is a bug in the code.  The code for this command checks to make sure the storage system is 8.2.0 or higher, but it does it incorrectly...it has this for the check:

    if ($versionComparisionValue -le 0 )

It should have this for the check, which is done correctly in the Modify volume command code:


if ( $versionCompareValue -ge 0 )

Mike

Re: Setting QosPolicyGroup in the "Create volume" workflow has a bug

Hi Mike,

We have already logged a bug for the same and addressing in up coming release. Your inconvenience is regretted.!

BTW, what is your ONTAP version.!

Regards

Sivaprasad K

Re: Setting QosPolicyGroup in the "Create volume" workflow has a bug

We are using 8.2.1X17, which is the EVP version of 8.2.1.

Mike

Re: Setting QosPolicyGroup in the "Create volume" workflow has a bug

Hi Mike,

WFA 2.1GA officially does support SN.0. The upcoming release will be handling SN.1 related content.

This command will work smoothly with SN.0. But yes, this check is nothing to do with SN.1 content

Regards

Sivaprasad k

Re: Setting QosPolicyGroup in the "Create volume" workflow has a bug

Yes, I can see that the comparison will work with 8.2.0, but it is still a bug, as the comparison should be –ge and not –le ☺.

Mike