Subscribe
Accepted Solution

Slow workflow execution with WFA 4.2

Hi,

 

We encounter slow workflow execution on our new WFA server (WFA 4.2 RC1).

 

The Create Volume command took 36219 milliseconds (>35 secs)  to complete. I am using a local user account with CRL (Certificate Revocation List) 

 

 

On the old WFA server (WFA 4.1), same command took 10344 milliseconds (>10 secs) to complete.

 

 Any suggestions appreciate.

 

Thanks,

Henk Snel

 

 

Re: Slow workflow execution with WFA 4.2

 

 

I meant to say that CRL is disabled for local user.

Re: Slow workflow execution with WFA 4.2

We noticed the same thing as well when we were testing out 4.2RC1.  We then tried to start the services with a domain user and it went super fast.

 

Can you test out that scenario as well to confirm?

 

 

Re: Slow workflow execution with WFA 4.2

Re: Slow workflow execution with WFA 4.2

^

Got 404 on the link

Re: Slow workflow execution with WFA 4.2

Re: Slow workflow execution with WFA 4.2

we have started the services under a domain user. The workflow execution is still very slow.....

Re: Slow workflow execution with WFA 4.2

Hi Henk Snel,

 

Please provide your machine configuration.

So that we will try to reproduce it locally

 

Regards,

Sundar

Re: Slow workflow execution with WFA 4.2

Hi Sundar,

 

 

This is the machine configuration:

 

CPU: Dual 2.50 Ghz Intel Xeon

Memory: 8092MB

OS version: Windows 2012 R2

System Type: Server (VMguest)

 

Thanks,

Henk Snel

 

Re: Slow workflow execution with WFA 4.2

Hi Sundar,

 

I've found the problem.

 

The problem is the slow loading of Powershell DataONTAp module within WFA. Which is 4.3.0.

 

I've replaced that version by 4.2.0 (which comes with WFA 4.1).

 

The volume create command now takes 10 secs to complete in stead of 40 secs.