Subscribe
Accepted Solution

Snapdrive - unable to select fiber initiator when connecting disk

Hi Team,

I am trying to connect a LUN to a physical server (Windows 2008 R2) using snapdrive v6.3. I can see the igroup (this has been deleted and recreated in snapdrive) no problem both through snapdrive and System MAanger.

When I go thorugh the 'Connect Disk Wizard' or 'Create Disk wizard' wizard with snapdrive on the server to either connect a LUN, or create a new lun, when I get to the Select Fiber initiators, I can see my two fibre cards but am not able to select either of them. I am at a loss as to why? - MPIO is installed

I have attached the screen where I can't select anything.

I have removed A/V and re-installed snapdrive

PLease ask if I should provide more information

Thanks

Re: Snapdrive - unable to select fiber initiator when connecting disk

I have the same issue.  Unable to select Fiber Channel Initiators

Brand new installation of Windows 2008 R2 Enterprise

Snapdrive 6.3.1R1

NetApp MPIO DSM 3.5

QLogic HBA

I'm able to create and rename IGroups from SnapDrive

LUNs that are mapped to server through NetApp OnCommand System Manager to not appear in SnapDrive but will give an error that the LUN is already connected if I try and connect the drive

Re: Snapdrive - unable to select fiber initiator when connecting disk

for the 2nd one, is this a cluster?

if so, you must remove snapdrive and reinstall after you have installed cluster services, then in snapdrive, you can select the clustered option.

Re: Snapdrive - unable to select fiber initiator when connecting disk

Uninstalled Snapdrive

Restarted server

Configured MS Cluster

Reinstalled SnapDrive

Same results.

Re: Snapdrive - unable to select fiber initiator when connecting disk

interesting.

did you unmap the lun completely, and then try snapdrive (with no mapped initiators)?

i have seen this issue before, just trying to go through my memory banks to remember how to fix it.

Re: Snapdrive - unable to select fiber initiator when connecting disk

I had this also with the lun saying it was already mapped. You need to clear the Initiator group in System Manager and recreate them either in System MAnager or Snapdrive.

I think it could be the zonining of the fibre cards on the switch...running some checks now.

FOUND IT! - in Zoning of the Fibre CArds - when you have finished the alias / zone / zone config - you neded to save the config and ENABLE the config. This worked for me and I can select the cards now.

Also, I would let SnapDrive create the LUNS. Create the Volume in System Manager but let Snapdrive create the LUN for you (Create Disk option in SnapDrive)

Re: Snapdrive - unable to select fiber initiator when connecting disk

Where do set the zoning for the fiber cards?

Re: Snapdrive - unable to select fiber initiator when connecting disk

Found it.

Need to add the NetApp to the zone for the Fibre channel cards.

Thanks for the quick response. 

Re: Snapdrive - unable to select fiber initiator when connecting disk

Hi, im seeing exact same issue but zoning looks ok, (We are using a cisco mds 9124 switch  ours says to activate rather than enable   (only difference))

Windows 2008

any other idea son resolving?

I can select the initiators when creating an igroup, fy