Community

Subscribe
Highlighted

Unable to restore a VM or mount a SnapVaulted backup

Using OnCommand console, I'm trying to mount a backup, and all I get is :

DX-FR-W8-VMW.france.xxx.com: OnCommandHSVMware: hsMount3 98b6e271e094a3d146cc9fff95657cc9: FLOW-11019: Failure in InternalMetadataFormatTask: No storage system configured with interface "10.20.30.206" (10.20.30.206)

In storage, this FAS2040 is well known by this IP address, but if it can help, its IP on 10.25 network must be used to be mounted on VMware, this is where the NFS network belong.

Backups are working fine

Re: Unable to restore a VM or mount a SnapVaulted backup

Hi,

As you are doing this operation from the backup node, Host Service might not aware of the credentials of the backup node. You need to push the credentials into Host Service using the below steps.

1. Go to Host Service page

2. Launch edit and push the credentials of the secondary controller(where you are trying to mount/restore the backup)

-KJag

Re: Unable to restore a VM or mount a SnapVaulted backup

That's an interesting answer, but this system do not appear in host services, because it is not used as a primary storage, only for snapvault, and because of that (VMware has no knowledge of a system at this IP) it does not show up.

I can add it manually in the service edit window, but when I confirm, it does not stick in the bottom list, only the primary systems currently mounted does.

I don't think this is the problem because it used to work with the same situation.

Envoyé de MobileMail

Le 7 mars 2012 à 07:31, "kjag" <xdl-communities@communities.netapp.com> a écrit :

Re: Unable to restore a VM or mount a SnapVaulted backup

created by kjag in OnCommand Mgmt Software - View the full discussion

Hi,

As you are doing this operation from the backup node, Host Service might not aware of the credentials of the backup node. You need to push the credentials into Host Service using the below steps.

1. Go to Host Service page

2. Launch edit and push the credentials of the secondary controller(where you are trying to mount/restore the backup)

-KJag

Reply to this message by replying to this email -or- go to the message on NetApp Community

Start a new discussion in OnCommand Mgmt Software by email or at NetApp Community

Ce message et éventuellement les pièces jointes, sont exclusivement

transmis à l'usage de leur destinataire, et leur contenu est strictement

confidentiel.

Si vous recevez ce message par erreur, merci de le détruire et d'en avertir

immédiatement l'expéditeur.Vous n'êtes en effet pas autorisé, dans cette

hypothèse,à copier, distribuer ou conserver ce message.

Re: Unable to restore a VM or mount a SnapVaulted backup

Can you check the is the job for pushing the credentials is successful?

Re: Unable to restore a VM or mount a SnapVaulted backup

ok...one more check.

Whats the IP Address the secondary filer is added in DFM?

-KJag

Re: Unable to restore a VM or mount a SnapVaulted backup

The same address in the error is its primaryAddress

Envoyé de MobileMail

Le 7 mars 2012 à 07:47, "kjag" <xdl-communities@communities.netapp.com> a écrit :

Re: Unable to restore a VM or mount a SnapVaulted backup

created by kjag in OnCommand Mgmt Software - View the full discussion

ok...one more check.

Whats the IP Address the secondary filer is added in DFM?

-KJag

Reply to this message by replying to this email -or- go to the message on NetApp Community

Start a new discussion in OnCommand Mgmt Software by email or at NetApp Community

Ce message et éventuellement les pièces jointes, sont exclusivement

transmis à l'usage de leur destinataire, et leur contenu est strictement

confidentiel.

Si vous recevez ce message par erreur, merci de le détruire et d'en avertir

immédiatement l'expéditeur.Vous n'êtes en effet pas autorisé, dans cette

hypothèse,à copier, distribuer ou conserver ce message.

Re: Unable to restore a VM or mount a SnapVaulted backup

I assume you didn't change the credentials of the primary controller. Also check in the bottom panel of the Host Service the primary controller is listed with everything good.

-KJag

Re: Unable to restore a VM or mount a SnapVaulted backup

Here we are :

Re: Unable to restore a VM or mount a SnapVaulted backup

IHAC who had exactly the same symptoms. The message was

No storage system configured with interface "192.168.x.x" (192.168.x.x)

The fix was to do "options license_feature.multistore.enable on" on the controller which is mentioned in the error message (running 8.1). The eventlog of the server where the Host Package is running (in the application branch of the event viewer) was pretty helpful there. Every other log I checked was a complete dead end.

I just wanted to mention this, because a google search for "No storage system configured with interface" yields exactly two hits, one of which is this thread.

After that I did "dfm hs controller setlogin -p https <HSID> 192.168.x.x" on the OnCommand Server and restarted the Host Service. Not sure, if the last one was needed, but after that the controller instantly appeared under the managed systems and everything worked.

cheers,

Patrick

Re: Unable to restore a VM or mount a SnapVaulted backup

I just got the same issue, one year later...

It looks like what actually solved it this time is setting hostPreferredAddr1 and hostPreferredAddr2 from dfm CLI

The controller cannot be added if its IP address cannot be matched with VMware mount I think.

I set the IP of the filer on the storage network as the hostPreferredAddr2 and after a refresh, the controller was there.