Subscribe

Upgrade from 6.4 to OCUM & OPM 7.0

[ Edited ]

Hello,

 

Does anyone know how we can clean up false credentials between OCUM & OPM after upgrade ?

 

After an Upgrade vom 6.4 to 7.0 I got following message in the dashboard for some systems with ONTAP9.

The issues is fixed as soon as I remove a cluster and add it again, but I will lost all the history.

 

"The credentials provided by Performance Manager for the user with Event Publisher role are either incorrect or Performance poll is not complete or has failed."

 

Best regards,

Marc

Re: Upgrade from 6.4 to OCUM & OPM 7.0

You can go to the new dashboard (landing page), and edit the cluster. The "Edit cluster" page has options for you to provide new username and password.

 

 

The new credentials you enter will be updated in both OCUM and OPM server.   It should work.  If it doesnt work, please let us know.

 

 

Regards,

Saravanan

Re: Upgrade from 6.4 to OCUM & OPM 7.0

[ Edited ]
Hello

I tried it, but it doens't work. I think it's not problem by the credentials.
Do you have any additional ideas?

Best regards
Marc

Re: Upgrade from 6.4 to OCUM & OPM 7.0

I am having the same issue with 7.0RC1 and I've reset permissions on that account several times.  I'm also conviced it's not actually a permissions issue.

Re: Upgrade from 6.4 to OCUM & OPM 7.0

I had a bad combo of user/password. After the upgrade, I created a new account and applied that. I noticed it was helpful to go ahead and restart the service first on Unified Manager followed by Perf Mgr. Pairing showed up healthy.

Re: Upgrade from 6.4 to OCUM & OPM 7.0

I added a second cluster to UM today and it worked fine with PM so I'll reset everything and see how it goes. Thanks!

Re: Upgrade from 6.4 to OCUM & OPM 7.0

Now we have two workarounds, but no idea how we can fix it without a new account or the lost of the history.

 

@dmcneil Did you switch back to the admin user? (I can't test it right now.)

Re: Upgrade from 6.4 to OCUM & OPM 7.0

I have found that my instance of 7 finally crashed and became inoperable. There may be some workarounds now so that may fix things. But history was lost 

Re: Upgrade from 6.4 to OCUM & OPM 7.0

Just in case anyone else runs into this issue.

 

The way to resolve it is to modify full integration settings (if option is enabled). Once you start to go through the diffrenet fields you will find that one of the opttions is a new account, called publisher admin.

 

6.4 did not have this account in the past, that is why the error is coming up. Once you set username and passwd for the publisher account and restart Performance manager services, OCUM will stop displaying the error. 

Re: Upgrade from 6.4 to OCUM & OPM 7.0

Hallo

 

Iam having the same Problem hier with OCUM  7.1P1  & OPM  7.1P1  

 

 

Monitoring staus

 

Pairing Status
(Bad):

The credentials provided by Performance Manager for the user with Event Publisher role are either incorrect or Performance poll is not complete or has failed.

 

Any ideas where the Problem can be ?

 

Thanks