Subscribe
Accepted Solution

Upgrading NetApp Harvest to 1.3 "Package netapp-harvest not installed, cannot update it."

Currently running version 1.2.2. Trying to upgrade to 1.3, but getting message:

 

[xxxxx:root]/tmp# yum upgrade -y netapp-harvest-1.3-1.noarch.rpm
Loaded plugins: package_upload, product-id, rhnplugin, security, subscription-manager
This system is not registered with RHN Classic or RHN Satellite.
You can use rhn_register to register.
RHN Satellite or RHN Classic support will be disabled.
Setting up Upgrade Process
Examining netapp-harvest-1.3-1.noarch.rpm: netapp-harvest-1.3-1.noarch
Package netapp-harvest not installed, cannot update it. Run yum install to install it instead.
No Packages marked for Update

Re: Upgrading NetApp Harvest to 1.3 "Package netapp-harvest not installed, cannot update it.&qu

Hi @dlmaldonado

 

Prior to v1.3 Harvest was available as a tgz only and not in rpm package format. So from a package perspective this is an initial install and not an upgrade.  So please use 'yum install" instead of "yum upgrade" for the 1.2.2 -> 1.3 situation.  I realize the user guide doesn't mention this situation, sorry for the confusion.

 

If this works please let us know and then 'accept as solution'.  Thanks!

 

Cheers,
Chris Madden

Solution Architect - 3rd Platform - Systems Engineering NetApp EMEA (and author of Harvest)

Blog: It all begins with data

 

If this post resolved your issue, please help others by selecting ACCEPT AS SOLUTION or adding a KUDO or both!

 

Re: Upgrading NetApp Harvest to 1.3 "Package netapp-harvest not installed, cannot update it.&am

Yes, this worked. Thanks Chris.

Re: Upgrading NetApp Harvest to 1.3 "Package netapp-harvest not installed, cannot update it.&am

[ Edited ]

HI Chris,

 

I'm also having problems upgradeing to 1.3.

 

Getting

 

Examining netapp-harvest-1.3-1.noarch.rpm: netapp-harvest-1.3-1.noarch
Marking netapp-harvest-1.3-1.noarch.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package netapp-harvest.noarch 0:1.3-1 will be installed
--> Processing Dependency: perl(Excel::Writer::XLSX) for package: netapp-harvest-1.3-1.noarch

Packages skipped because of dependency problems:
    netapp-harvest-1.3-1.noarch from /netapp-harvest-1.3-1.noarch

 

Have installed excel to no avail.


cpan[2]> install Excel::Writer::XLSX
Excel::Writer::XLSX is up to date (0.95).

 

 

Output from  "rpm -ivvh netapp-harvest-1.3-1.noarch.rpm" says excel is not a dependency but it complains it's not there.

 

D:  Requires: perl(Excel::Writer::XLSX)                     NO

 

Cheers

Re: Upgrading NetApp Harvest to 1.3 "Package netapp-harvest not installed, cannot update it.&am

Hi @Mal-R

 

I suspect the rpm dependency checker only knows if the package is there if it was installed using an rpm and not from cpan directly.  Google returned this Stackoverflow post which says the same.

 

To resolve you could just run this to get all required packages again:

sudo yum install -y epel-release unzip perl perl-JSON \
perl-libwww-perl perl-XML-Parser perl-Net-SSLeay \
perl-Time-HiRes perl-LWP-Protocol-https perl-IO-Socket-SSL
sudo yum install -y perl-Excel-Writer-XLSX

or maybe use the --no-deps flag to skip the check since you have the module already.

 

 

Cheers,
Chris Madden

Solution Architect - 3rd Platform - Systems Engineering NetApp EMEA (and author of Harvest)

Blog: It all begins with data

 

If this post resolved your issue, please help others by selecting ACCEPT AS SOLUTION or adding a KUDO or both!

Re: Upgrading NetApp Harvest to 1.3 "Package netapp-harvest not installed, cannot update it.&am

Reinstalled perl and excel to no avail.

 

Using --nodeps option worked.

Now collecting Ontap 9 metrics.

 

Thank you

Malcolm

Re: Upgrading NetApp Harvest to 1.3 "Package netapp-harvest not installed, cannot update it.&am

Hi,

 

have the same issue RHEL 7.3 and tried all your options. Didn't work.

 

 yum install -y netapp-harvest-1.3-1.noarch.rpm
Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-manager
Examining netapp-harvest-1.3-1.noarch.rpm: netapp-harvest-1.3-1.noarch
Marking netapp-harvest-1.3-1.noarch.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package netapp-harvest.noarch 0:1.3-1 will be installed
--> Processing Dependency: perl(Excel::Writer::XLSX) for package: netapp-harvest-1.3-1.noarch
--> Finished Dependency Resolution
Error: Package: netapp-harvest-1.3-1.noarch (/netapp-harvest-1.3-1.noarch)
           Requires: perl(Excel::Writer::XLSX)
**********************************************************************
yum can be configured to try to resolve such errors by temporarily enabling
disabled repos and searching for missing dependencies.
To enable this functionality please set 'notify_only=0' in /etc/yum/pluginconf.d/search-disabled-repos.conf
**********************************************************************

Error: Package: netapp-harvest-1.3-1.noarch (/netapp-harvest-1.3-1.noarch)
           Requires: perl(Excel::Writer::XLSX)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[root@localhost tmp]# yum install -y perl-Excel-Writer-XLSX
Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-manager
No package perl-Excel-Writer-XLSX available.
Error: Nothing to do

 

Error: Nothing to do
[root@localhost tmp]# sudo yum install -y epel-release unzip perl perl-JSON perl-libwww-perl perl-XML-Parser perl-Net-SSLeay perl-libwww-perl perl-XML-Parser perl-Net-SSLeay
Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-manager
No package epel-release available.
Package unzip-6.0-16.el7.x86_64 already installed and latest version
Package 4:perl-5.16.3-291.el7.x86_64 already installed and latest version
Package perl-JSON-2.59-2.el7.noarch already installed and latest version
Package perl-libwww-perl-6.05-2.el7.noarch already installed and latest version
Package perl-XML-Parser-2.41-10.el7.x86_64 already installed and latest version
Package perl-Net-SSLeay-1.55-4.el7.x86_64 already installed and latest version
Package perl-libwww-perl-6.05-2.el7.noarch already installed and latest version
Package perl-XML-Parser-2.41-10.el7.x86_64 already installed and latest version
Package perl-Net-SSLeay-1.55-4.el7.x86_64 already installed and latest version
Nothing to do
[root@localhost tmp]# yum install -y perl-Excel-Writer-XLSX
Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-manager
No package perl-Excel-Writer-XLSX available.
Error: Nothing to do
[root@localhost tmp]#

 

 

Any ideas?

 

Best wishes,

Markus,

 

 

Re: Upgrading NetApp Harvest to 1.3 "Package netapp-harvest not installed, cannot update it.&am

Hi @scheckel

 

 

In the output I see "No package epel-release available."  The XLSX package is in EPEL so I think you would need to:

 

 

wget https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm
sudo
yum install epel-release-latest-7.noarch.rpm

 

Then try that XLSX package install again.

 

Alternatively, you could use the --no-deps option when installing Harvest  [unless you are planning to use the perf-counters-to-excel.pl utility go generate XLS spreadsheets of object inventory].

 

Hope this helps!

 

Cheers,
Chris Madden

Solution Architect - 3rd Platform - Systems Engineering NetApp EMEA (and author of Harvest)

Blog: It all begins with data

 

If this post resolved your issue, please help others by selecting ACCEPT AS SOLUTION or adding a KUDO or both!

 

Re: Upgrading NetApp Harvest to 1.3 "Package netapp-harvest not installed, cannot update it.&am

Try using this if you have downloaded the rpm.

 

 rpm -ihv netapp-harvest-1.3-1.noarch.rpm --nodeps

 

It should get the upgrade done.

 

Cheers