Subscribe

User Inputs - Query to populate table (predefined choices)

Building a workflow that typically creates 3 volumes. Want to use a table in the input field where one of the column is pre-populated with valid choices.

 

Setting the column and adding the query works and it test ok, see below. If I try a preview, everything the drop down is there as expected but not populated (last screenshot)

 

Any idea?

 

 

2015-12-03_14-12-29.jpg

 

 

2015-12-03_14-13-30.jpg

 

2015-12-03_14-14-06.jpg

 

2015-12-03_14-14-50.jpg

Re: User Inputs - Query to populate table (predefined choices)

Your inconvinience is regretted. This is a documented limitation with this feature. The Query User-Input at the Table columns need to be independent an independent query. If is  has a dependent input like you have in your case, Test will work but during workflow execution it will not be able to resolve the Query based on the Input you provided.

 

This is a feature limitation. The Query for a Table comlumn has to be an *independent* query. 

 

WFA may resolve this in future.

 

sinhaa

 

 

 

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: User Inputs - Query to populate table (predefined choices)

[ Edited ]

Wondering if this feature (allowing dependencies in Table field Query column SQL) in WFA 4.0?

 

I checked the Release Notes New Features section for 4.0RC1 and don't see it ... but thought I'd ask anyway in case it slipped in.

 

Re: User Inputs - Query to populate table (predefined choices)

@dkorns

 

No, its not there in 4.0. I believe this has a technical challenge which may be difficult to resolve.

 

sinhaa

 

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: User Inputs - Query to populate table (predefined choices)

Is this going to be looked at further or does someone know if they can fix that technical difficulty?

Re: User Inputs - Query to populate table (predefined choices)

[ Edited ]

Apologies but upon further testing I think my issue is different than above.  I'll continue testing and reply back when I can confirm or deny.  Thanks,

Re: User Inputs - Query to populate table (predefined choices)

[ Edited ]

I'm interested in the topic of workarounds on this as well. But first, Ben: can you elaborate more what you mean by "I can do 1x level of dependent SQL input queries, where 1 dropdown list is dependant upon selection from a parent dropdown list". Are you saying you can reference a '${userInputVar}' varaible in your SQL for a Table Column of Type Query? I ask because I thought the issue was you basically can not make 'any' outside references to other UI variables in the same table or elsewhere of any other UI fields of any type (string, enum, etc). That's what I think I was seeing.

 

As for workarounds, there could be some topic-specific work arounds. If folks share what they're trying to do with their table input, we could all share workaround ideas.

 

In the case I'm thinking of (filling out a table of info to create SVM LIFs ... like IP, home-port, etc) the only work around I can envision is to just NOT ask the user for certain information and have workflow logic that auto-determines what you originally envisioned as a dependent-SQL Query. That's not easy in many cases with multiple nodes, ports and VLANs. 

 

FWIW EDIT:

   ... for clarity, I attached this dar file which is the simplest workflow to demo the problem. Look at the Table column to select an aggregate. I'd like it only show certain aggregates (those whose name contains the operator selected string), but because the attempt to reference another UI variable doesn't work, it has to list all aggregates. I've commented out the WHERE clause that doesn't work properly at execution (it works in test-mode). Un-comment to see the problem. 

 

 

 

 

Re: User Inputs - Query to populate table (predefined choices)

[ Edited ]

To clarify - I'm using a custom CSV datasource of a table of network devices.  Table is a list of devices, their corresponding clusters and their corresponding datacenters.  The workdlow has 3 dropdown menus for user input that query this table:

 

1-distinct list of datacenters.

2-distinct list of clusters.  Datacenters is mandatory so this dropdown should only display clusters matching the chosen datacenter.

3-distinct list of devices.  If clusters is left null then all devices in datacenter chosen by query 1 should are returned for user to select.  If a cluster is chosen then only devices matching both datacenters and clusters are returned for selection.

 

Query 3 is dependant on selections from both query 1 and 2, however query 2 should not be mandatory.

 

When testing SQL logic individually all 3 queries operate properly and return desired results.  But when I Preview or Execute the workflow, while selections to both queries 1 and 2 DO affect the results show by query 3 properly, the field for query 2 remains blank even after making a selection.  Because the field is blank the workflow fails saying that a selection is missing.  I've already verified query 2 is not mandatory within the command's powershell script or variable settings.