Subscribe

VCenter Data Source Issue

Anyone get the error "You cannot call a method on a null-valued expression." when trying to acquire data from VCenter. I have tried it on two of my VCenter servers, and they both fail.

Re: VCenter Data Source Issue

Hi

    This is a known issue, this is the root cause of the problem.

When you have a datacenter , but no host attached , we get the below mentioned error  Error running data acquisition script: You cannot call a method on a null-valued expression.

The workaround for the same is "Removing the empty datacenter"

Request you to open a case with NetApp support against bug 736081.

Here is the public report for the same with workaround.

VMware vCenter data source acquisition fails when the vCenter server includes either no datacenter object or empty datacenter objects

DESCRIPTION:

VMware vCenter data source acquisition in OnCommand Workflow Automation (WFA) fails and WFA displays the following error messages:

1. "Error running data acquisition script: Cannot validate argument on parameter 'Datacenter'.

The argument is null or empty. Supply an argument that is not null or empty and then try the command again."

Cause: There is no datacenter object added to a vCenter.

2. "Error running data acquisition script: You cannot call a method on a null-valued expression."

Cause: There are datacenter objects added to the vCenter, but no host is attached to the datacenters.

WORKAROUND:

Remove the empty datacenters or datastores from the vCenter server and retry data source acquisition.

Regards

adai

Re: VCenter Data Source Issue

Thank you for the quick response.

Is it just empty 'Datacenters' or empty clusters an issue too?

Are empty datastores an issue as well?
What is the ETA for a release that is able to error proof the script? IE if ($datacenter = $null){continue} else{gatherfurtherdeta}

I appreciate any input you may have.

Re: VCenter Data Source Issue

Hi

I am not sure of the ETA for the release, netapp support should be able to help you on this front. Pls open up a case against the bug nubmer that I gave.

With respect to clusters I will check and get back to you.

Regards

adai