Subscribe

WFA 4 caching old values?

Hi,

we are running WFA 4.0RC1 due to following:
own db schema filled by script
finder access to own schema
The naming convention requieres to find the next free volume numbers (checking the gaps) and use it for new volumes.

The workflow as follows:
User selects location and service type
with the imported ocum annotations and the user input, the svm name is evaluated
the Freevolume table is truncated
a perl script queries all volumes for the svm from the database, find the free volumes and writes the result into the Freevolumes table
the Freevolumes table is queried to get the volume names one by one.
The steps 1-4 are working. If I run the "Test" on step 5, I get the right result. If I execute the workflow, I always get a result that contains a result that was valid on the run before.

Furthermore, during the execution the variable holding the result is alredy defined (see screenshot)

What's wrong here?

Marcus

Re: WFA 4 caching old values?

@marcusgross

 

You need to provide the workflow exported in .dar format. Debugging designer issues without the dar is like shooting in dark.

 

Please export your workflow and attach here.

 

sinhaa

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: WFA 4 caching old values?

Here is the worfklow as dar file.

Re: WFA 4 caching old values?

@marcusgross

 

Workflow dar is not enough, It has a User-Input $service query doing s SELECT on a table which is not the scheme of the workflow/commands. The table cm_annotation_ocum.annotations_ocum is not in the dar.

 

sinhaa

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: WFA 4 caching old values?

[ Edited ]

Hi,

 

the result of the user input is the SVM name, based on annotation of OCUM.

It was set up this way to hide technical detailes from the user.

 

table.png

 

The freevolumes table looks like this:

 

table1.png

 

The last 4 digits of the SVM are the digis 2-5 of the volume name.

 

Re: WFA 4 caching old values?

@marcusgross

 

Marcus,

 

Unfortunately the images you posted are still not enough to debug this issue. Since its a custom workflow, If you are not able to resolve this issue yourself, I would suggest you take NetApp PS help for resolving this.

 

sinhaa

 

 

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.