Subscribe
Accepted Solution

WFA Create Volume

Hi all

 

I have two problems with the create volume command in WFA.

 

As of best practises in a SAN environment we should not mount FC volumes into the global namespace but the "Create volume" command exactly does that. Is there a way to use this command but not to mount the volume into namespace?

 

The other one is if we want to set the auto_delete_options in WFA the destroy_list key cannot contain multiple values. Is there a way to achieve that?

 

Regards and thx

Dario

 

Re: WFA Create Volume

Which mode are you using, 7-mode or Cluster mode?

 

In the "Create Volume" command in Cluster mode, the option has been parsed.

The same can be done for the destroy_list also.

 

if($AutoDeleteOptions)
{
Get-WFALogger -Info -message $("Configuring auto delete options " + $AutoDeleteOptions)

foreach ($option in $AutoDeleteOptions.split(","))
{
$option = $option.trim();
$pair = $option.split(" ");

 

Regards

Abhi

Re: WFA Create Volume

Thanks for the quick reply.

 

We're using the cluster mode..

 

I've seen the code but the problem is for the destroy_list are multiple values acceptable like this:

"state on, trigger volume, target_free_space 15, commitment destroy, destroy_list lun_clone vol_clone cifs_share file_clone sfsr"

 

And I always get the following error:

Got wrong autodelete option pair destroy_list lun_clone vol_clone cifs_share file_clone sfsr. Options should be in key value format.

 

Regards

Dario

Re: WFA Create Volume

The error is from here:

 

        if($pair.Length -ne 2)

        {

        $msg = "Got wrong autodelete option pair " + $option + ". Options should be in key value format."

        throw $msg

        }

 

"state on, trigger volume, target_free_space 15, commitment destroy, destroy_list lun_clone vol_clone cifs_share file_clone sfsr."

 

Remove sfsr, it will work. That is the odd one in the comma seperated list.

 

Regards

Abhi

Re: WFA Create Volume

Dario,

@Snashot Autodelete 

---

 sfsr is a valid option. This code is not well written to take multiple values for option destroy_list. It assumes that like other keys this too can only take one value which is not true. This is a Bug.

 

 

@Junctionpath 

---

 

This too is a problem as it will always set Juctionpath for the created volume irrespective of whether the user wants it or not.

 

A bug in the product shall be raised and it will be fixed in the future release. In the meantime if you are okay to use a non-netapp certified command, I cane give you the fix that will solve both. 

 

sinhaa

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: WFA Create Volume

Run into the same issue attached is the create volume for SAN command ( for cluster mode )

Re: WFA Create Volume

Thanks for the replies.

I've made my own commands. One for unmounting the volume after it has been created and the other one for settings the snapshot autodelete options.

This is because i don't wanna touch the certified commands.

 

Is there already a bug open for these topics?

 

Re: WFA Create Volume

Bugs have been filed for those.

 

Burt ID:  887550, 887533 

 

If you want you may a file customer support case with NetApp to raise the priority for the fixes.

 

sinhaa

 

 

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: WFA Create Volume

Hello,

 

is there any fix for that "junction-path" problem meanwhile?

 

We don't want junction-path active and set for ouir SAN Workflow ...

 

Would be nice for any reply.

 

Thx

Marcel

Re: WFA Create Volume

I can send you my self created command if you want..