Subscribe

WFA - Intermittent Error - Could not get credentials for xx-xxxx

Hello,

Is anyone aware of  solutions outside of ensuring  IIS and  W3SVC have been disabled for this intermittent error?  It still persists for me even with upgrading WFA to the latest version.  The particular workflow where we are experiencing the error is leverging the following cmdlets.

 

Set-NaVolSize

Get-NaVolSize

Get-NaSnapshotReserve

Get- NaAggrSpace

 

Thanks, 

David

 

 

"Message": "Unable to execute workflow(NAME=sAPI_NAS_Volume_Resize v1.0), WFA(status=FAILED), Error: Could not get credentials for <xxx>. \nCause: The remote server returned an error: (404) Not Found.. The remote server returned an error: (404) Not Found.",

    "Action": "Please verify request."

 

Code:

#Defined Parameters
param(
[parameter(Mandatory=$true,HelpMessage="Array name or IP address")][string]$Array,
[parameter(Mandatory=$true, HelpMessage="Volume name")][string]$VolumeName,
[parameter(Mandatory=$true, HelpMessage="Volume Size")][int]$VolumeSize
)
#connnect to controller
Connect-WfaController -Array $Array

 

#Gather Return Params

$AggrName = ((Get-NaVol $VolumeName).Aggregate)

$totalSpace =(Get-NaVolSize $VolumeName).VolumeSize/1GB
$primarySpaceAllocated =(Get-NaVol $VolumeName).SizeTotal/1GB
$snapshotReserveAllocated = (Get-NaSnapshotReserve $VolumeName).size/1GB
$aggrCapacityCommited = (Get-NaAggrSpace $AggrName).SizeVolumeAllocated/1GB

 

#Define Return Params

Add-WfaWorkflowParameter -Name CompletionStatus -Value $command_comp
Add-WfaWorkflowParameter -Name VolUuid -Value (Get-NaVol $VolumeName).uuid
Add-WfaWorkflowParameter -Name VolStatus -Value (Get-NaVol $VolumeName).state
Add-WfaWorkflowParameter -Name VolAggr -Value (Get-NaVol $VolumeName).Aggregate
Add-WfaWorkflowParameter -Name VolVfiler -Value (Get-NaVol $VolumeName).OwningVfiler
Add-WfaWorkflowParameter -Name totalSpaceAllocated -Value $totalSpace
Add-WfaWorkflowParameter -Name primarySpaceAllocated -Value $primarySpaceAllocated
Add-WfaWorkflowParameter -Name snapshotReserveAllocated -Value $snapshotReserveAllocated
Add-WfaWorkflowParameter -Name aggrCapacityCommited -Value $aggrCapacityCommited

Re: WFA - Intermittent Error - Could not get credentials for xx-xxxx

Hi David,

        Kindly get in touch with NetApp Global Support and raise a customer case. WFA is already looking to find root cause on this bug.

 

Your inconvinience is regretted.

 

sinhaa

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.