Subscribe

WFA OnCommand Insight Connector Pack version 2.0

[ Edited ]

Hi All,

 

There is an OnCommand Insight Connector version 1.2 available on Automation Store. I'm attaching the version 2.0 with the following improvements.

 

  1. Fixed failures arising due to scalability. The code scalability has been improved by more than 700x. Big improvement.
  2. Added Host-specific Logger for easy execution trace.
  3. Removed Get-WfaLogger and the unnecessary REST calls it was making. This should speed up code execution
  4. Support for OnCommand Insight 7.2

 

How to use this pack?

 

1. You need WFA4.0 to import this .dar pack. WFA4.0 RC1 is available here. The new WFA4.0 has many improvements in designer, Pack management, latest security patches, and many bug fixes. See release notes for the details. I would highly recommend to upgrade your WFA.

2. After importing you'll see a new Data Source type : OnCommand Insight Abhishek.Sinha@netapp.com

3. Add a new Data Source for this type, providing credentials etc. and you are done.

 

For users on WFA3.0,3.1

 

If you are still on WFA3.0 or 3.1 and do not want to  upgrade now, you can do the following:

1. Import the OnCommand Insight Connector on your WFA.

2. Go to WFA-> Designer-> Data Source Types and clone the Data Source : OnCommand Insight.

3. Rename it to OnCommand Insight 2.0 and update the version to 2.0.0

4. Copy the code from the attached WFA40_OnCommand_Insight_Abhishek_Sinha_netapp_com_V20.txt into the code section.

5. Save it. Your new DataSource version is ready.

 

For users on WFA2.2 and below

 

You can't use this OCI connector with WFA versions lower than 3.0.

 

For any issues, do post them on WFA Community. They will be resolved promptly.

 

sinhaa

 

 

 

 

 

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.