WFA error "Uanble to find API"

Getting the below error frequently however it is not consistent, sometimes the workflow executes as expected without any issues.  Is this a symptom of an overloaded controller?

"Failed to create new volume TSDEPG. Message: Unable to find API: volume-get-iter on node vserver us01cm01vs1"

NetApp Employee

Re: WFA error "Uanble to find API"


I am assuming that the version of WFA is 2.1.

You will see this error if you are choosing a 'NODE' vserver to create a volume instead of a 'DATA' vserver.

Ideally, the resource selectors should not allow you to select a Node Vserver in the first place.

However this is being fixed in the later releases.

Let me know if you have any other issues.



Re: WFA error "Uanble to find API"

Hi Kramar:

Are you using a sample workflow or is this a custom workflow?

If it is a sample workflow, can you also let us know the workflow name.


Re: WFA error "Uanble to find API"

Hi Jim,

     This error message is a pure ontap one and has nothing to do with WFA, I did some internal search on the bug list and found bug 715129 which talks about this and is Duped to bug 720174.

The public report mentions to contact netapp support for workaround or the fix for the same is available in ONTAP release starting 8.2.1RC1 and later.



Re: WFA error "Uanble to find API"

Thanks for all the responses, I think it led me in the right direction.  It looks like ONTAP is interpreting the vserver as a "node" vserver, however it is in fact a "data" vserver.  Most of the BURTs relate to cluster setup and or join failures causing the data vesrevers to be interpreted as node vservers.  However in this case all looks healthy from this aspect:

us01cm01::*> debug cluster-setup show

Task ID SubTask ID Status     Tries Failures

-------------------- ------------------------- ---------- ----- -------

network-setup enable-switchless success 0       0

network-setup lif-check success 0       0

network-setup cluster_ha_check success 0       0

network-setup relabel-lifs success 0       0

node-check rpc-check success        0 0

node-check register_mgwd_dsmfp_service

success 0       0

system-initialize get-node-name success 0       0

start-rdb check-node-name success 0       0

start-rdb resolve-aggr-names success 0       0

start-rdb system-initialize success 0       0

cluster-create create-site-list success 0       0

cluster-create join-site-list success 0       0

cluster-create wait-for-rdb-online success 0       0

cluster-create wait-for-rdb-databases success 0       0

system-startup populate-limits success 0       0

check-cluster-apps add-license success 0       0

check-cluster-apps upload-capability success 0       0

check-cluster-apps add-cluster-name success 0       0

vldb-update insert-lifs success 0       0

vldb-update system-startup success 0       0

vserver-mgmt vldb success        0 0

cr-mgmt lifmgr success 0       0

cr-mgmt bcom success 0       0

cr-mgmt register-aggregates success 0       0

cr-mgmt create-cserver success 0       0

cr-mgmt initialize_vsMsidStatusTable

success        0 0

cr-mgmt create-predef-roles success 0       0

flexcache-mgmt publish-host-based-keys success 0       0

28 entries were displayed.