Subscribe
Accepted Solution

WFA - "Create VMware vDisk" command does not work

Hi,

 

I'm trying to create a vDisk on a virtual machine.

I'm using the Netapp created WFA command "Create VMware vDisk".

The tab "VMname" asks me to define a vm. So I'm using the optin "by searching for an existing Virtual_Machine" and find my vm via filter ("name equals $VMname").

 

When the WFA is doing the preview of the workflow, everything is alright, it finds my vm and "creates" a vDisk.

But when I'm executing the workflow in production, it throws an error ( "the argument for the parameter "name" cannot be checked. The argument is null or empty").

Using a filter on "UUID" gives me the exact same error.

 

So why is the preview working but not the actual execution.

 

Thanks for your support.

Re: WFA - "Create VMware vDisk" command does not work

@b22

 

I'm using the Netapp created WFA command "Create VMware vDisk".

----

 

If by 'NetApp created'  you mean NetApp provided and certified (for correctness in functionality), then I don't think there is any such command given by NetApp. If you have obtained this command from a NetApp Professional services, then you have option to ask for PS support on it. If its created by you or your team, the netapp open community is the right place to ask questions on it and hope for an answer.

 

 

 

So why is the preview working but not the actual execution.

----

You need to understand what is this 'Preview'.

A workflow execution is a 2 step process

 

1. Preview or Planning

2. Command code execution

 

A preview is workflow 'planning'. What happens in preview?

  

Its finds your resources as per your selection criteria.

Resolves user-inputs

It prepares what inputs to be passed to command parameters.

A command to be excuted or not based on your condition.

 

etc. 

WFA developer's guide will give the whole list of actions WFA does during preview.

 

In broad terms its makes your workflow ready for execution. NO Command code executes during Preview. Failure in 'Preview' happens when any of the above fails which means your workflow is not ready for execution phase. 

 

 

Sucess in Preview doesn't assure that the command code will also pass.  There is NO way for WFA to predict will the code pass or not. Preview can only say what arguments will be passed to parameters in the command code during the next phase which is code execution.

 

The error you are getting it ( "the argument for the parameter "name" cannot be checked. The argument is null or empty").

 

is thrown during execution phase. It means you need to check you command code.

 

sinhaa

 

 

 

 

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: WFA - "Create VMware vDisk" command does not work

Thanks for the answer.

The command was automatically installed after I downloaded the vc package from the onlione automation store, so i assumed it was Netapp created..

After reading your comment I checked the code and found the issue.

 

So for anyone wanting to use this command:

The two lines of code after "# get cluster by provided name" are not necessary and can be deleted. The comnmand works fine after doing that.