Subscribe

You can not add Security group in version 3.1, 3.1.1

Hi, to the new version OnCommand SM do not add security groups to share folders (AD).

Users are fine.

Will fix?

Re: You can not add Security group in version 3.1, 3.1.1

Which version of ONTAP are you managing?

Thanks,

Kevin

Re: You can not add Security group in version 3.1, 3.1.1

NetApp Release 8.1.3 7-Mode

Adding group permissions on shell with command cifs access works fine.

Re: You can not add Security group in version 3.1, 3.1.1

If I understand the problem correctly, it should be possible.

Can you share a screenshot of the problem?

Thanks,

Kevin

Re: You can not add Security group in version 3.1, 3.1.1

When trying to add Domain group by OnCommand System Manager on CIFS share, textbox UserGroup goes highlighted with red line and it is imposible to add group, no error appears. This function was working in previous releases of OnCommand System Manager like a charm.

Trying on Internet Explorer version 10.0.9200.16897

Re: You can not add Security group in version 3.1, 3.1.1

Thanks for the screenshot. 

Can you include the error message text from the User/Group field outlined in red (hover over it to get an error message)? 

Kevin

Re: You can not add Security group in version 3.1, 3.1.1

I tested this on 3.1RC1 and found it says "Unknown Unix group <groupname>".

Let me investigate further and report back.

Kevin

Re: You can not add Security group in version 3.1, 3.1.1

You are right, on hover appears "Unknown Unix group <groupname>". The same error appears when I try to add domain group on shell with cifs access -g Domain\group "Permission", but typing cifs access Domain\group "Permission" adds permission successfully. So probably "-g" option is the root of problem when used with domain group.

Re: You can not add Security group in version 3.1, 3.1.1

Since there is no API call to manage CIFS shares in that manner, OCSM must use the "system cli" API and run a command as if it were on the controller CLI.

It appears something changed although it is not yet clear if that was ONTAP or OCSM - the investigation continues.

When there is a likely cause identified a bug will be filed on the appropriate product and I will post it here.

Thanks,

Kevin

Re: You can not add Security group in version 3.1, 3.1.1

Bug 822758 was filed to track and resolve this behavior.

Once there is information you will be able to watch it here:

http://support.netapp.com/NOW/cgi-bin/bol?Type=Detail&Display=822758

The workaround is to use the ONTAP CLI without the -g option.

Thanks,

Kevin