Subscribe

cDOT quota rule command

Hi,

has somebody already done quota management on clustered ONTAP?

I need 2 commands

quota policy create

and more important:

quota policy rule create -vserver VSERVERNAME  -policy-name default -volume VOLUME -type tree -target q_target -disk-limit SIZE

Otherwise i will create it by myself.

Best wishes,

Markus.

Re: cDOT quota rule command

Added an example workflow.

Can create quota rules but not enable the quota on a volume with ps command

enable-NcQuota -Volume $VolumeName  -VserverContext $VserverName -controller $Cluster

getting "API invoke failed" even direct on powershell it wont work.

So is this an issue on the powershell toolkit?

Best wishes,

Markus.

Re: cDOT quota rule command

Hi Markus,

I imported your workflow and removed the "-controller" input parameter in the command code. It works fine. The powershell cmdlet is as  follows,

enable-NcQuota -Volume $VolumeName  -VserverContext $VserverName  (No -controller input)

The command executed successfully. Command output,

12:08:20.484 INFO  [enable CM Quota] ### Command 'enable CM Quota' ###

12:08:21.890 INFO  [enable CM Quota] Executing command: ./enable_CM_Quota8641471582266480103.ps1 -VserverName vs1 -VolumeName test_vol1 -Cluster 10.68.66.160

12:08:21.906 INFO  [enable CM Quota] Get-NaCredentials -Host 10.68.66.160

12:08:21.921 INFO  [enable CM Quota] Credentials successfully provided for '10.68.66.160'

12:08:21.953 INFO  [enable CM Quota] Connect-NcController (with credentials) -Name 10.68.66.160

12:08:25.031 INFO  [enable CM Quota] Connected to cluster node

12:08:25.046 INFO  [enable CM Quota] Enabling quota on a volume- name '' , volume name 'test_vol1' , vserver name 'vs1'

12:08:27.250 INFO  [enable CM Quota] Command completed, took 6766 milliseconds

Note:  The value to the input parameter -controller is "parameter returned by the Connect-NcController cmdlet". If not specified, the value in the global variable CurrentNcController is used.  So In WFA Command code after "Connect-WfaCluster $Cluster"  not need to use that input parameter explicitly.

Regards,

Satish.