Subscribe

enable rbac sdcli dfm_config

Hello,

i try to enable rbac with my dfm/snapdrive. Since it is impossible to copy paste here anything. i added a file with the Problem.

The User is added on DFM Server with GlobalFullControl.

What i make wrong? I my eventlogs i found no additional Infos.

thanks

Re: enable rbac sdcli dfm_config

hi,

following are the steps to configure,

- SDW needs to be installed with the DFM server settings like DFM  server name/ IP Address, User name, PWD. ( The Username should at the least have  DFM.Core.AccessCheck in the global scope on the DFM )

are you sure you have given the user name with the DFM.Core.AccessCheck permission.

then try to set SDW with the information.

thanks, Prabu

Re: enable rbac sdcli dfm_config

Hi,

the User has DFMGlobal Full Control.

EU.BSHG.COM\MCH-sds_tdfmGlobalFullCo...

regards Soeren

Re: enable rbac sdcli dfm_config

Hi,

Is the hostname (mchwtdfm01 ) of DFM is pingable from the SDW machine?

-KJag

Re: enable rbac sdcli dfm_config

Its on the same System, and i tried also with IP. And yes its pingable.

Re: enable rbac sdcli dfm_config

DFM Zapi failed to connect to the DFM server 'mchwtdfm01'.

To me this means that the user who is running the SDW service is not able to connect to the DFM server.

Can you please check the below points on the DFM server

Make sure DFM server is running & using port no. 8088

(Run the below commands & check

dfm service list

dfm option list serverHTTPPort)

Re: enable rbac sdcli dfm_config

well, all services running and http port is 8088

Re: enable rbac sdcli dfm_config

if DFM is windows machine,

make sure you have created a same user under Local Users and Groups in windows.

creating a  user in DFM doesnt create a user in windows,

also you can use the following command.

sdcli dfm_config set -host mchwtdfm01 -user MCH-sds_tdfm -pwd XXXXX

no need to give domain name too. try this hope it works.

thanks, Prabu

Re: enable rbac sdcli dfm_config

DOH! i forget this Point, i will do it after Eastern and try again and give then full pts. Thanks for the hint.

Re: enable rbac sdcli dfm_config

DFM authenticates users based on the operating system it is installed on and expects an existing user in the environment.

Solution


Windows environment:
Specify a user local to the Windows Server, a Domain user or group.

Anyway, i createt a user local on the System and put him direct to the Administrators. dfm user add  username

But i still get the error.